こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

NET Framework 1.1 SP1を再インストールする方法が分

NET Framework 1.1 SP1を再インストールする方法が分かりません。

Microsoft .NET Framework 1.1 SP1 用セキュリティ更新プログラム (KB979906) が、
ずっとインストールできないので、NET Framework 1.1 SP1を再インストールして、
再び更新プログラムをインストールしようと思っています。
ちなみにこういう状態で更新ができません。
http://oshiete.goo.ne.jp/qa/6057510.html

そこでですが、NET Framework 1.1 SP1の再インストールの方法を教えてください。

あと、PCにはNET Framework 2.0 service pack2、NET Framework 3.0 service pack2、
NET Framework 3.5 service pack1もインストールされているのですが、
NET Framework NET Framework 1.1 SP1だけ再インストールしても問題ないでしょうか?

もしどなたか分かりましたら、よろしくお願いします。

投稿日時 - 2010-09-12 11:20:08

QNo.6176664

困ってます

質問者が選んだベストアンサー

#3です
>アンインストールする時は大きいのからですね。
これはその通りなのですが(SPがあればSP類から)
※ Ver2.0~3.5の.NetFrameworkでの話

>インストール時は小さいのから
此方はちょっと違います
たとえば何もない状態にいきなり3.5を入れようとしても問題ありません
3.5インストール時に勝手に下位の必要バージョン(2.0)もインストールされます
(トラブル対策という意味では自分で順番にやったほうが正解かも)

.NetFrameworkは各バージョンで以下の4系統に分かれています
各系統に関して互換性はありません(系統という言葉は今回便宜上勝手に使っているだけ)
(見た目はVerの違いですが別のソフトと考えて差し支えないです)
1.Ver1.0系統
2.Ver1.1系統
3.Ver2.0~3.5系統
4.Ver4.0系統(現在の最新)

>そのせいで、プログラムの一覧を見ると、1.1が2つインストールされた状態になっていました。
正確に再起動などを行っていれば普通はそのようにはなりませんが
どこかで必要な動作を行わなかったのでしょうね
  一番高い可能性として考えられるのは
  アンインストール後再起動しないままに再インストールしたのではないかと思います
  (このよなことをやるとそうなったりすることがあります)

通常インストール済みの環境に再セットアップでは修復などになるだけで
そのような状況にはならないはず

>こういう場合、どうしたらよいでしょうか?その状態で放っておいても、
>1.1自体に影響はないでしょうか?あと、他の2.0~3.5にも影響ないでしょうか?
基本的には問題無いはずです(実際何か問題が出ていますか?)
どうしても気になる場合はレジストリ編集することで治せると思いますが
慣れていない人がやると最悪システムが起動しなくなりますので
わからないなら見た目は我慢するほうを選択しましょう
(アプリケーションの追加と削除に2項目出てるってだけですよね?)

投稿日時 - 2010-09-22 09:27:23

お礼

お返事遅くなりました。
お回答ありがとうございます!
アプリケーションの追加と削除に1.1が2項目出てるというだけです。

投稿日時 - 2010-10-18 00:13:25

ANo.4

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(5)

ANo.5

当方は最近、Vista SP2 にて NET Framework 1.1 の再インストールを行いました。詳細を次のページに書きました。特に、その中の[復旧の手順]をご覧下さい。healthysauさんも、同じ様に行って治るかもしれません。なお、手順の中で使うNET Framework 1.1 関係のプログラムは全てマイクロソフトのダウンロードセンターからダウウンロードして使いました。

【タイトル 及び URL】
.NET Framework 1.1 の初めからの再インストール。(『ディスクのクリーンアップ』がトラブルの原因であった様である。)
http://social.technet.microsoft.com/Forums/ja-JP/windowsvistaja/thread/cdadccf9-6f9a-4691-8ecf-6110c777808c

------
当方のパソコンでは、Roxio EasyMedia Creator 9 をインストールするとき、自動的にNET Framework 1.1 がインストールされます。

経験からして、NET Framework 1.1 と NET Framework 2から3.5 は独立してインストール・アンインストールが行えるようです。

投稿日時 - 2010-10-06 16:40:26

ANo.3

>NET Framework NET Framework 1.1 SP1だけ再インストールしても問題ないでしょうか?
Ver3.5(2.0~3.5) と Ver1.1に互換性はありませんので
Ver1.1を使っているアプリケーションがなければ
アンインストールしても何の問題もありません
もっともなんらかで使われたからインストールされたと思うので
その意味では(アプリがわからないのであれば)お勧めできません

1.1のみを(SP含め)削除・再インストールもできるはずです

一方3.5の方は(2.0~3.5)と書いたようにセット品と考えてください
3.5があるから2.0は削除できる  ということにはなりません
仮にアンインストールの際はバージョン大きいものから小さいのもを順番に
アンインストールしないとアンインストールできません(エラーになります)
でもって3.5だけインストールしようとしても勝手に2.0もインストールされます

投稿日時 - 2010-09-12 13:48:03

お礼

お返事遅れました。
http://blog.yoshida-ya.biz/?eid=154によるとインストール時は小さいのからですが、
アンインストールする時は大きいのからですね。
教えていただきありがとうござます。

ちなみに改めて分かったのですが、1.1が既にインストールされているのに、もう一度1.1をインストールしてしまいました。
そのせいで、プログラムの一覧を見ると、1.1が2つインストールされた状態になっていました。
こういう場合、どうしたらよいでしょうか?その状態で放っておいても、1.1自体に影響はないでしょうか?あと、他の2.0~3.5にも影響ないでしょうか?

もしよければ教えていただけるとうれしいです。

投稿日時 - 2010-09-22 04:40:12

ANo.2

何か、NET Framework 1.1 SP1を必要とし動かないソフトが
あるのでしょうか?
そうでなければ、インストールする必要はありません。

これをやろうとすると、他を消してバージョンの古い順
から、インストールた方が良いと思います。。

http://support.microsoft.com/kb/923100/ja

どうしても、再インストールされたいのであれば、提示urlの
文中にある「.NET Framework Cleanup Tool」を使用して一旦
全て削除し、頭から再インストールをお勧めします。
「.NET Framework Cleanup Tool」
http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx

蛇足ですが
「.NET Frameworkをアンインストールしてはいけません!」
http://blog.yoshida-ya.biz/?eid=97
「いっそのこと「.NET Framework」を全削除してインストールし直しませんか」
http://blog.yoshida-ya.biz/?eid=154

投稿日時 - 2010-09-12 11:59:43

お礼

お返事遅れました。分かりやすいURLも教えていただきありがとうござます。
OSはXPですが、1.1のインストールを要求されてたり、1.1をインストールした覚えもなく、いつの間にかインストールされていました。

ちなみに、もしよければ教えていただきたいのですが、NET Framework 1.1 SP1を必要とするソフトはどういうのがありますか?

投稿日時 - 2010-09-22 02:59:29

ANo.1

[.NET Framework]はWindows XPの標準状態ではインストールされておらず、
[.NET Framework]が必要なアプリケーションのインストール時にインストールされるようになっていました。
Windows VISTAでは、標準状態で[.NET Framework 3.0]がインストール済みですが「プログラムのアンインストール」には表示されません。
[Norton Ghost 15]のように[.NET Framework 2.0]以上が必要なアプリケーションをインストールするときも
上位バージョンがインストールされているので、下位バージョンのインストールは必要はありません。
 例外的に、古いソフトの中で(OfficeXP plusなど)[.NET Framework 1.1]を要求するものがあり、
その場合はインストールされていなければ「インストールを要求する」確認メッセージが出ます。

投稿日時 - 2010-09-12 11:43:42

お礼

お返事遅れて申し訳ありません。
ちなみにOSはXPなのですが、1.1を要求された覚えもインストールした覚えもなく、いつの間にか1.1がインストールされていました。

投稿日時 - 2010-09-22 02:51:28

あなたにオススメの質問