こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

Dell Precision Workstation 530

DELLのPrecision Workstation 530というXeonマシンを数日前より個人で使っています。

内蔵HDDコントローラがATA100までしか対応しておらず、現在私の使っているSATA IのHDDに比べて随分遅く困っていました。
そこで、余らせていたPCIのSATAカードを刺してSATA IのHDDを使おうと思うのですが、増設したSATA HDDからブートしてくれません。

どうすれば良いでしょうか?
他のPCならBIOSの所をSCSIにしてやればブートがかかるのですが…。
よろしくおねがいします。

投稿日時 - 2006-01-23 21:31:58

QNo.1916569

暇なときに回答ください

質問者が選んだベストアンサー

>元々OSの入っていた内蔵ATAドライブを繋ぐとそいつから起動します。
>そのドライブから起動させた場合はマイコンからSATAドライブが見えます。

との事ですから、起動以外は正常動作をしていると考えられますね。

今、DELLのページを覗いて見たのですが気になる記述を見つけました。
BIOS設定の項目なのですが「内蔵デバイスを有効または無効にするには、セットアップユーティリティを起動し、Integrated Devicesを選択し、適切なデバイスの設定をOnまたはOffに変更します。」
というのがあり、SCSIもこの項目にあるようなことが書かれています。

BIOSでこの項目を探し、SCSIを有効にし、起動デバイスの変更ができるか試してみて下さい。
(ひょっとしたら起動デバイスに出なくても、SCSIを有効にしHDDをSATAにするだけで動くかもしれませんが・・・)

#同じ機種を持っていないので試せませんので・・・

うまく行くと良いのですが・・・

参考URL:http://supportapj.dell.com/support/edocs/systems/ws530/ja/index.htm

投稿日時 - 2006-01-26 00:59:00

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(3)

ANo.2

なんだか、「前提をきちんと書かない」のにアドバイスに関して鼻で笑われたような気がするので(そのつもりがなくても文章ではニュアンスは伝わらない)とっても気分が悪いのだが、乗りかかった船なのでもう1度だけ書いておく。

SATAからブートしたいんだよね?

#1で書いた手順で、そのPCで、そのSATAカードで、そのHDDでOSのクリーンインストールしたんだよね?
(他のPCで動いていたのを転用なんて大バカな事はしていないよね?)

パラレルのHDDを外して、SATAのHDD1個だけにして作業するぐらいのことは「勿論」してるよね?

インストール作業は進んでいるはずだから、BIOS上でのHDDは表示されているよね?

んで、そこまでやっておいて「SATAが起動ドライブにならない」って言ってるんだよね?

ここもでちゃんとやっていれば後はBIOS設定だけのはずだ。質問文は正しい。


ここまでやっていないんなら最初の質問文が違うはずだ。(やってないのか?鼻で笑ってやろう。)
SATAのHDDにOSインストールが出来ない・・って質問になるはずだが?

インストール作業がうまくいかないのならメインPCのSATAカードと交換して動作確認してるよね?


・・・・と書かれていてもこの文章なら気分が悪いと思う。

もう一度質問者としてのスタンスを確認し、文章が相手にどう伝わるかを考慮したほうが良いと思います。
また、どこまでやったのかを補足として記載するべきだと感じます。

当初の質問文だと何をどこまでやったのかが読み取れません。
正しい情報が提供されてこそ正しい解答が帰ってくるはずです。

どんな作業をして、現在どこで悩んでいるのかを補足願います。

投稿日時 - 2006-01-25 00:13:14

補足

言葉足らず、そして説明不足で、不快な思いをさせて申し訳御座いませんでした。
緊急の事だったので焦っていました。

メルコのIFC-ATS2P2というSATAカードを挿し、SATAハードと繋ぎ、FDからブートをかけてXPのインストールをしました。
その際に、F6を押し、IFC-ATS2P2カードを読み込ませ、SATAハードをインストール先に選びインストールしました。
間違えて初期化してしまわぬよう内蔵ドライブはCD-ROMドライブ以外、外付けも含め外し、問題が起きぬよう拡張カードもビデオ、SATAカードだけにし、メモリも初期の512Mの状態に戻し、インストールしました。
インストールですが、SATAハード内にセットアップに必要なファイルをコピーするだけで、XPのインストールは開始されていません。
(ブルーバックに白文字の画面のところまでしか進んでいない)
本来なら、HDD内にコピーが終わったら一旦再起動し、16色か256色位のGUIの画面に切り替わるのですが、SATAからブートがかからないので、そこの画面に到達しません。
元々OSの入っていた内蔵ATAドライブを繋ぐとそいつから起動します。
そのドライブから起動させた場合はマイコンからSATAドライブが見えます。

説明不足な点があれば補います。どうぞよろしくおねがいします。

投稿日時 - 2006-01-25 14:16:03

ANo.1

SATAからのブート以前に、OSのインストール自体は終わっているのでしょうか?

Windowsのインストールの際にSATAカードのドライバをインストールする必要があります。

OSのCDから起動→SATAのドライバインストール→OSのインストールの手順を踏まないとブートドライブになりません。

確か、OSインストールが始まった直後にF6あたりを押してフロッピーからドライバを入れたかと思います(XPで作業をした記憶あり)

手順に関してはもっと詳しい方が居るかと思いますが、SATAカードのマニュアルを読み返せば全部書いてあるはずです。(ジャンク品や玄人志向の場合は御容赦を)

参考までに

投稿日時 - 2006-01-24 10:38:59

補足

OSをインストールしていなければブートどころか起動すらしませんよ。

同じSATAカードを2枚持っていて一枚はメインPCで稼動中
もう一枚を取り付けたのですが、マニュアルによると、
ブートドライブを『SCSI』にしてやれば起動すると記載されています。
現にメインPCの方はFASTBOOTをSCSIにしてやることによりSATAから起動しています。

しかしこの530はBOOT設定がDisket(A:)、CD-ROM、HardDiskの3つしか選択肢がありません。よってどうやって設定するのか分からずじまいでした。

投稿日時 - 2006-01-24 21:38:29