こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

HUBが動作しない

現在このように接続しています。回線はCATVです。

元―HUB―PC1
    |
     ―ルータ―PC2

この時、ルータの設定で擬似MACアドレス(PC1のアドレス?)を登録すると二台どちらも使えるようになります。

しかし、時々繋がらなくなります。PCの場所の移動等で全部やり直した時もうまくいかない時があります。
対処の仕方が分からないので諦めてほっとくといつのまにか繋がっていたりすることもあります。
繋がっている時は「元―HUB」の所でHUBのランプが点灯してますが、繋がらない時は点灯していません。

何故繋がったり切れたりするのでしょうか?対処法を教えてください。

HUBはLD-CSW05N/SV(http://www2.elecom.co.jp/network/hub/100mbps/ld-csw05n/index.asp)
ルータはAtermWR7800Hワイヤレスセット(TU)です。
OSは2台ともXPです。
また配線の都合上、できれば上図の通りがいいです。

よろしくお願いします。

投稿日時 - 2006-08-02 00:02:49

QNo.2314052

暇なときに回答ください

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(5)

ANo.5

モデムと無線ルータを長いLANケーブルで繋いで、1階のPCに近い場所にルータを配置しているという事でしょうか?
それでしたら、ルータのLANポートとPC1を長いLANケーブルで繋げば、HUBは必要ないですし、2台のPCが直接ルータの配下になりますので、IPマスカレードが有効になり、2台のPCを同時にインターネットに繋ぐ事が出来ます。

投稿日時 - 2006-08-03 01:24:41

お礼

ありがとうございます。
持ち合わせの物でやったのであのような配線でした。あまりお金を使いたくなかったのですが、無線からPC1へ繋げるLANケーブルを買うことも検討してみます。

しかし無線って条件が厳しいですね。友人宅では全部屋ちゃんと繋がるのに・・・。
ちなみに今はHUB通して繋がるようになりました。takaya0131さんの仰るDHCPの取得が関係しているのでしょうか?

投稿日時 - 2006-08-03 09:56:28

ANo.4

>えっ!そうなんですか!二台同時に使えていた記憶が・・・

使えていたとしてもDHCPのアドレス取得等で問題が生じますので、PCは必ずルーターの下流に接続してください。

投稿日時 - 2006-08-02 00:43:10

お礼

そうなんですか。ありがとうございます。
一度繋がればそんなにしょっちゅう切れたりすることもないので、dwarf-v50さんの補足で述べた事情もあり、できればあの配線ままにしておこうと思っています。
ただ原因としてはDHCPのアドレス取得(意味がよく分かりませんが・・・)に問題があるってことなんですね

投稿日時 - 2006-08-02 01:22:08

ANo.3

元-ルーター-PC1
      |
       ―PC2
と繋がないとPC1とPC2の同時インターネット使用はできません。HUBはルーターのLAN端子が2つ以上あれば不要です。お手持ちのルーターの説明書をもう一度読み返してください。

投稿日時 - 2006-08-02 00:15:14

補足

>PC1とPC2の同時インターネット使用はできません。
えっ!そうなんですか!二台同時に使えていた記憶が・・・

投稿日時 - 2006-08-02 00:25:15

ANo.2

pc1とpc2のDHCP取得はどうなっているのでしょうか?。ルーターの配
下にhubを置くのが普通なんですが・・・そのあたりの構成がよく判らないところですが・・。

投稿日時 - 2006-08-02 00:11:33

ANo.1

普通は

インターネット-モデム-ルータ-PC1
               │
               PC2

と繋ぐのが一般的だと思うのですが、なぜ違う繋ぎ方なのでしょうか?    

投稿日時 - 2006-08-02 00:07:53

補足

私の家は二階建てなのですが、PC1は二階にあります。
そしてPC2とルータは一階にあります。そしてCATVの回線は二階に引きました。当初は仰る通りにルータから分配しました。ちまみにこのルータは無線LANです。PC1は有線で、PC2は無線で接続しました。しかし無線が一階まで届きませんでした。仕方がないのでHUBを買って来て、まずそこで分配して、無線LANは無線がPC2に届く範囲まで持ってくるようにしました。
それでちゃんと二台とも繋がってくれたので現在は先の図のような配線で使用しているのです。(もっとも今は繋がりませんが...)

投稿日時 - 2006-08-02 00:11:26

あなたにオススメの質問