こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

AC'97 Audio Codecs がインストールできません

初めまして。
早速ですが、質問させて頂きます。

つい最近Vista搭載のPCを購入したのですが、録音ソフトなどを使ってもマイクの音しか録音できませんでした。
録音デバイスをみるとステレオミキサーがないので、それが原因かと思いいろいろ調べてみると、AC'97 Audio Codecsをインストールすれば表示されるだろうということで、ダウンロードしインストールしようと試みたのですができませんでした。
「Windows セキュリティがドライバ ソフトウェアの発行元を検証できませんでした」とでます。
これ自体は特に問題ないと思い「このドライバ ソフトウェアをインストールします」を選んでも、何度も「Windows セキュリティが」と出てきてまったくインストールが進みません。
一応ユーザーアカウント制御を切ったりしてみたのですが解決できませんでした。

サウンドチップはRealTek社製のALC 262です。
AC'97 Audio Codecs以外に解決できるものがあるのでしょうか。High Definition Audio Codecsはすでに試しています(インストールできたが、ステレオミキサーは表示されず)。
何か心当たりだけでもいいので、返信して頂けると幸いです。
では、よろしくお願い致します。

投稿日時 - 2007-06-05 20:18:41

QNo.3059476

困ってます

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.4

NO1です。
データを頂けましたのでちょこっと調べました。
この機種では背面青のミニジャックがラインイン、赤がマイクですね。

取りあえず、録音ソフトについては置いておいて、
一つこちらで見落としていた物があったのでそれを・・・

コントロールパネルのサウンドで録音タブをチェックしてみて下さい。
ここに出ているオーディオ録音デバイスにラインインはあるでしょうか?
無い場合、ドライバに問題があると思いますのでNECに質問した方がよいと思います。
(ダウンロードにこの問題用のモジュールが出ませんでした ドライバがうさんくさい)

ラインインがある場合、録音ソフトとの相性が気になります。


実際私は別途音源ボードを追加しているので録音も問題が無く、あまり気にしたことがありませんでした・・・汗

投稿日時 - 2007-06-06 00:57:11

お礼

またご意見を頂けるとは、ありがとうございます。

そうですね、ライン入力は表示されています。
それと録音ソフトですか・・・。
今回使おうとしているのは「Fraps ver2.8.2(シェアウェア版)」で、他なら録音できるかな?と試したのが「Audacity ver1.2.6」と「♪超録 ver1.25(フリーウェア版)」です。
上記3点とも録音できませんでした。(正確にはマイク入力しか録音できませんでした
以前のPC(XP SP2)では「Fraps」だとPC上の音声がすべて録音され、超録ではマイク入力のみが録音されていました。

上の3点のみで録音できないと判断しましたが、他にも試してみる価値はありますでしょうか。
もちろんこちらでもまた調べてみます。

このような時間までご回答頂いたことに感謝致します。

投稿日時 - 2007-06-06 01:35:07

ANo.3

録音デバイスのところで無効なデバイス表示にチェックをいれれば、ステレオミキサーが表れると思いますので、ステレオミキサーを標準に設定すれば普通にできると思いますが。

投稿日時 - 2007-06-06 00:51:51

お礼

ご回答ありがとうございます。

無効なデバイスの表示にはチェックを入れています。
それでも表示されなく、私以外にもそういった症状の方がいらっしゃいますので、今現在Vistaユーザーの間で問題となっており、No.2様にお答えいただいたように、面倒かつ解決できない方もいるといった状況になるわけです・・・。

ですが、私自身を含め、今後この(・・・えーと、スレッド?質問?でいいのかな・・・)質問を見る方々にとって初歩的なミスは十分にありえると思いますので、貴重なご意見です。
感謝致します。

投稿日時 - 2007-06-06 01:20:44

ANo.2

「AC'97 Audio Codecs」というのは一昔前のPCのオンボードサウンドに使われていたAC'97 Audio用のドライバの一種です。
現在ではオンボードサウンドはHigh Definition Audio(HDオーディオ)へ統合されており、導入しても意味はないと思われます。

Vistaでステレオミキサーが表示されないといった不具合は質問者さんだけではなく、多くのVistaユーザーが抱える慢性的な問題です。
つまりOSに問題があるようで、根本的な原因までは特定できませんが、一説ではVistaのサウンド面の技術的な問題だと言われています。

今秋リリース予定が噂されているSP1の内容では改善される可能性もありますが、今のところは具体的な対策法はないかもしれません。
かなりの情報通の方なら対策法がわかるかもしれませんが、現在の段階では私の耳には入ってきていません。
現在の情報では他にもSigmaTel製オーディオデバイスにも同様の問題が発生しているということぐらいです。

実際の解決にはならないかもしれませんが、以下のサイトを参考にしてみてください。
http://www.atamanikita.com/stereo_mix_00.html
http://oshiete1.goo.ne.jp/qa2990513.html
http://d.hatena.ne.jp/insp/20070413

投稿日時 - 2007-06-06 00:16:09

お礼

なるほど・・・。丁寧なご回答ありがとうございます。

一昔前の・・・ですか。私の勘違いだったわけですね。
今回は「Vista ステレオミキサー」で検索した時に、2人ほど解決したという例を見かけた(と思いこんだ)ので私の環境でもドライバによる解決策があるんだ、と思ったことから質問させていただきました。
ですが、どうやらいろんなワードや組み合わせで検索しすぎて混乱してしまったのかもしれませんね・・・。
1つの諦めと別の策への決心を与えて頂いたことに感謝致します。

実は、お金をかければ他の解決策がある旨を友人から聞いていたのですが、私のケチなわがままで皆様を振り回してしまいました。申し訳ございません。
これからはマイクのインターフェースから分割してサウンド入力インターフェースとスピーカへ繋げるための分割器(言葉が大量に間違っているかもしれませんが)を購入する方向で模索していこうと思います。
そんなわがままに貴重な時間を費やして付き合って頂いたお二方及び、回答しないまでもこの質問をご覧下さった方々に謝罪と感謝を申し上げます。

投稿日時 - 2007-06-06 00:49:27

ANo.1

PCがどこのメーカーか書いていないと正確な返答がしにくいですね。
個人的にはドライバの他に接続の物理的な間違いの可能性も指摘したいです。

むしろコーデックはあまり関係ないような・・・?

投稿日時 - 2007-06-05 23:32:10

お礼

さっそくの回答ありがとうございます。

うーん、接続ですか・・・。
それは内部の可能性もありますか?
外部は説明書も見ずに接続していたので確認してきましたが、特に問題があるようには見えませんでした。
コーデックは勘違いでしょうかね・・・。

それと、指摘されたメーカー等を書いておきます。

メーカー:NEC製品
型番:PC-GV21YTZR6
CPU:インテル(R) Core(TM) 2 Duoプロセッサー E6400 (2.13GHz)
メインメモリ:4GB(DDR2/677 1GB*4)
グラフィックボード:GeForce7600GT
VRAM:256MB

これぐらい書けば十分でしょうか・・・?もし足りなければ随時書き足していきます。

投稿日時 - 2007-06-06 00:11:12

あなたにオススメの質問