こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

TCP/IPだけが通らないのですが、、、

IBM ThinkPad 240Z を使用しています。
元々PCの付属のイーサネットポートで社内LANに接続していたのですが、
あるときからインターネットに接続することができなくなりました。
但し、Microsoftネットワーク、Netwareネットワークは共に接続ができます。
Pingコマンドでサーバーに打つと返ってこず、自分のIPに打つと返ってきます。
勿論、IPアドレス、サブネット、ゲートウェイ、DNS等の設定は問題ありません。
恐らく、TCP/IPが正常に動作していないようなのですが、コンパネのネットワーク
から、TCP/IPを一旦削除し再度インストールしてもダメです。
どうしてなのでしょうか?何を調べたらいいのでしょうか?
どなたか至急に教えて下さい。大変困ってます。 

投稿日時 - 2002-07-09 12:10:09

QNo.309947

すぐに回答ほしいです

このQ&Aは役に立ちましたか?

4人が「このQ&Aが役に立った」と投票しています

回答(8)

ANo.8

MicrosoftネットワークはNetBEUIorIPXがバインドされているということですよね?
で、NetBEUIやIPXは正常に通っているとなると、
レイヤ2層以下は問題なしということでソフト的なものかと。
TCP/IP関連のドライバ類が問題ないとすると、あやしいのはルーティングでは無いでしょうか?
route printでDefaultRoute(0.0.0.0)やDefaultGateway宛のルーティング先(Gateway)が
正常になっているか確認してみてください。

もし見方がわからなければ、補足で出力結果を貼り付けてください。
(IPアドレスがグローバルの場合はマスクしておいて下さい)

あと、TCP/IPだけではなくネットワークの設定全てを削除してみても同じですか?

投稿日時 - 2002-07-10 10:49:19

ANo.7

コンパネ>ネットワーク
の使用しているLANアダプタのプロパティに、
「詳細設定」タブは存在していますか?

存在する場合はその「詳細設定」の「プロパティ」で、
10/100mbpsおよびfull/halfの切り替えが出来るか
確認してみて下さい。

出来る場合は10mbpsのfull/half、100mbpsのfull/half
をそれぞれ指定してみて下さい。

投稿日時 - 2002-07-09 22:56:20

ANo.6

#1 です。

前に私も 全てのPC間(問題のPCも含め)で
ファイルの共有、サーバーへのアクセス、ネットワークプリンター への出力等々
全て問題なく作動していたのですが、それなのに問題のPCからだけはルーターが見えない(インターネットに接続できない) という事がありました。

結局 ハブのポートを差し替えるだけで解決したことがありました。

不思議なことに 問題のポートに別のPCを繋いでも
問題は再発しませんでした。

 今もって不思議です。

投稿日時 - 2002-07-09 16:06:48

補足

HUBのポートも替えたし、HUBも替えたし、LANケーブルも替えたし。

後は何をすればいいのでしょうか?

2~3日ほっとけば直るかも、、、としか思えなくなってきました。

投稿日時 - 2002-07-09 17:47:33

ANo.5

そうですね、確かにTCP/IPがおかしいようですね。まあ、無いとは思いますが、該当の機種のLANカードのIPアドレスの振り間違え、サブネットマスクの振り間違えあたりが一番可能性として高いのですが。次は、LANカードにTCP/IPがバインドされていないとか・・・

ドメイン・ワークグループなどは間違っていても、pingは通ると思いますので・・・・DNSも間違っていても問題ないと思いますし・・・

投稿日時 - 2002-07-09 15:38:25

補足

そうなんです。ぼやきたくなる現象です。

IP、OK。サブネット、OK、ゲートウェイ、OK。。。。。

TCP/IPは Intelのアダプタで、PCに純正についていたもので、
以前は正常稼動していたから問題ないはずなのですが、、、、

ドメインは使用していないし、ワークグループはちゃんと認識しているし、、、、

泣けてきます。

投稿日時 - 2002-07-09 17:44:20

ANo.4

NO.2で投稿いたしましたWingardです。

隣のPCにもとどかないということは、
1.HUBが故障した
2.LANケーブルが断線した
3.ポート自体が壊れた(ノートPC側の故障)
の3パターンが挙げられると思います。

まず、1の場合を考え、
他のPCから他のPCへ接続できるかを試してみてください。
もし普通につながっているようでしたら、
次にHUB側の差込口を取り替えてみて、
それでもだめなら次の2の場合を考えます。

2の場合は、一つ目の方法は、
クロスケーブルで他のPCとじかにケーブルをつなぎ、
お互いにPINGが通るかどうかをやってみてください。
それができないのでしたら、
HUBからつながっているLANケーブルをまるまる取り替えてみて、
新しい(もしくは確実につながっていることが確認できる)
ストレートケーブルを使って、
同じように他のPCにPINGが飛ぶかどうかを試してみてください。

それでもなおできないのでしたら、3の場合、
やっぱりノートPC側のポートが壊れたんだと思います。
修理に出すか、PCカードなどを使って
別のネットワークを確立するか、してみてください。

もしPCカードを今すぐ用意できるのでしたら、
先にそちらで試せば上の1・2は試すまでもなく
PC側の故障だということが分かるのですが・・・。

投稿日時 - 2002-07-09 14:56:04

補足

大変丁寧にご説明頂きありがとうございます。

が残念ながらハード的な故障は見つかりませんでした。
各機器,ポート、PCの入れ替えなどを行っった結果PCに問題あると
思われます。また、ネットワーク診断機器で各機器の正常を確認しています。

どうやっても抜け出せないところに来たようです。

誰か、助け出してください。

投稿日時 - 2002-07-09 15:17:26

ANo.3

こんにちは、お困りですね。

さてご質問の件ですが、
>Microsoftネットワーク、Netwareネットワークは共に接続ができます。

これがどの様な状況なのかちょっと分かりませんが。

>同じハブにぶら下がった横のPCにも届きません。
>勿論。そのPCからThinkPadまでも届きません。
一般的にこういった状況であれば、ハブが故障したと考えるのが普通だと思いますが。

ハブの他のポートに付け替えてみる・他のハブと交換してみる、あたりを試すとどんな状況になるでしょう?

投稿日時 - 2002-07-09 14:10:47

補足

Microsoftネットワークはハブを越えた共有されたPCを見ることができると
いうことです。
Netware はNetwareサーバーに接続し、ファイルサービス、プリントサービスを
受けられるということです。

ので、ハブの故障ではありません。但し、ハブがTCP/IPだけを通さないというの
であれば別ですが、他のPCをそのハブのそのポートに接続すると、正常に接続
が可能です。

ということで、混迷しています。 助けてください。

投稿日時 - 2002-07-09 15:12:59

ANo.2

簡単に言うと、内部ネットワークは正常、
外部ネットワークに接続できないってことでしょうか?

あと、ゲートウェイまではPINGは通ってますか?

投稿日時 - 2002-07-09 13:00:36

補足

ゲートウェイまでとどきません。
また、同じハブにぶら下がった横のPCにも届きません。
勿論。そのPCからThinkPadまでも届きません。
よろしくお願いします。

投稿日時 - 2002-07-09 13:29:23

ANo.1

”あるとき”に何をしたんでしょうか?
 (わかりゃ 苦労してない って言われればそうなんですが(笑)

まずは、一般的に
 1 最新のドライバーを探して入れる。
 2 再インストールする
  
でしょうけれども 逃げとして
誰か PCカード型LANカードは余ってませんでしょうか?
それで1度試してみるのも良いかも。
もちろん本体側のアダプタは使用不可にして

                でぁでぁ

 

投稿日時 - 2002-07-09 12:53:04

あなたにオススメの質問