こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

【助けて】Win2KSP4インストール後、旧HDD認識不良

新しくHDDを買ってきて、Win2k SP4をインストールしました。
その後、データの入っている300GのHDDをつなげました。
OSを起動し、古いHDDを見てみると、0バイトでフォーマット
しろと言われてしまいました。
あわてて、NOを選択し、レジストリをいじって137G以上を
認識できるようにしたのですが、古いHDDは”フォーマット
されていません”となります。BIOSは300Gを認識しています。
コンピュータの管理から記憶域をみてみると、128Gが
正常(アクティブ)となっており、残りは未割り当てとなって
しまっています。
なんとかデータを復旧させる方法はありませんでしょうか?
どなたかご教示ください。結婚式の写真などが入っているので
どうしても復活させたく、お願いいたします。

投稿日時 - 2007-07-29 11:17:43

QNo.3208992

すぐに回答ほしいです

質問者が選んだベストアンサー

なぜか2000やXPでこの事故が多いんです。私も何度か
経験してます。幸い生活にかかわるデータはバックアップを
しっかりとってありますので、被害はほとんどありませんが。

マスターブートレコードと・・・・・が壊れたのが原因ですが
修復方法はあります。

まず何か吸出しツールで必要なデータを取り出します。
ファイナルデータが有名ですが  http://www.finaldata.jp/
私は 無料時の http://www.vector.co.jp/soft/win95/util/se410717.html
を持ってますのでこれで吸い出しました。
全部だと大変でしたが、必要なものは特定の拡張子のもの
だけでしたので、すべて回収できました。
http://www.sourcenext.com/titles/sys/80330/ の
前バージョンでも吸出しが可能でした。

で、本題ですが・・・・HDD全体を復旧させるにはこちらを参照し
てください。理解力と時間が必要ですが回復できたときの
喜びを期待して作業を進めましょう。
http://lets-go.hp.infoseek.co.jp/testdisk1.html

がんばってください。

投稿日時 - 2007-07-30 08:38:06

お礼

お返事遅れて申し訳ありません。
結局FainalDataで吸出ししました。
ありがとうございました。

投稿日時 - 2007-08-05 22:48:27

このQ&Aは役に立ちましたか?

9人が「このQ&Aが役に立った」と投票しています

回答(5)

ANo.4

IDE0,1 って区別しているようだけど こうなってるよね?

IDE0 - HDD3
IDE1 - HDD2


こうじゃないよね?
IDE? - HDD3 - HDD2
or(IDE? - HDD2 - HDD3)

もしそうなら接続間違い

投稿日時 - 2007-07-29 13:55:11

お礼

ご返信ありがとうございます。
確認しましたが、
IDE0:HDD3
IDE1:HDD2
の接続になっています。

投稿日時 - 2007-07-29 14:09:03

ANo.3

#1です。
なるほど。ごめんなさい、私には原因がわかりません。

とりあえずknoppixなどでHDD2の中身が正常か確認して、正常ならデータのサルベージだけ行えばよいのではないでしょうか。

ちょっと手荒ですけど、その後フォーマットしちゃえば多分使えますよね。

投稿日時 - 2007-07-29 12:36:00

ANo.2

もっと解りやすく説明してください。
大体は、推測出来ますが、
古いHDDとは、データの入っている300Gのことですね。

古いHDDは、元々 どのような[ OS ]で、使用していたものですか??。
フォーマットが、違うと 認識されず、0バイトでフォーマット
しろと言われてしまいます。



また、< 128Gが正常(アクティブ)となっており、残りは未割り当てとなって>
とありますが、Win2k SP4をインストール時128Gのパーティションを作成し そこに、インストールしたのでは、ありませんか??。

投稿日時 - 2007-07-29 11:41:10

お礼

ご返答ありがとうございます。
説明が下手で、もうしわけありません。

まず、HDDは3台あり、
HDD1:120G 以前にOSのドライブとして使っていたもの。Win2k SP4
HDD2:300G 以前のデータ保管用として使っていたもの。
NTFSフォーマット。古いHDDといっているもの。
HDD3:320G 今回購入してきたもの。Win2k SP4をインストールした。

旧構成:
OS:Win2k SP4
IDE0 HDD1 120G
IDE1 HDD2 300G(300Gで認識して使えていました。)
HDD1にWin2k SP4をインストールし、HDD2はデータ保管用としていた。
HDD2にはOSインストールはしていない。

新構成:
OS:Win2k SP4
IDE0 HDD3 320G(実際には、128GにOS入りで、残りはまだ未設定)
IDE1 HDD2 300G
HDD3を購入してきて、Win2kをインストール後、SP4を当てる。
その後レジストリをいじって137の壁問題をクリアする。
HDD2は触っていない。フォーマットもインストールもしていない。

この状態で、HDD3が128Gなのは問題ありません。(未設定のため)
しかし、HDD2まで128Gかつ、参照出来ないのが問題となっております。
OSは新旧ともにWin2KSP4となっております。

投稿日時 - 2007-07-29 12:23:29

ANo.1

ただOSを変えただけなんですよね?
フォーマットさえしなければ、データが消えることはないと思います。

落ち着いて、以前HDDが認識されていた状況を整理するといいと思います。OSは何だったのか、など。

投稿日時 - 2007-07-29 11:25:20

お礼

早速のご返答ありがとうございます。
すみません。言葉足らずでした。

Before:
HDD1 120G OS Win2K SP4
HDD2 300G
After:
HDD1 320G OS Win2k SP4 ←新しく購入したHDD
HDD2 300G        ←以前のものそのまま

という構成です。OSは変えていません。HDD1を交換し、OSを新規
インストールしたら、上記のようになってしまいました。
OSはWin2kのSPなしをインストール後に、SP4を当てています。
ちなみに、もう一度古い構成にしてみましたが、同じ現象の
まま(300Gを認識しない)になってしまいました。

投稿日時 - 2007-07-29 11:37:34

あなたにオススメの質問