こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

WindowsとLinuxがネットワーク接続できません

お世話になります。
Windows端末とLinux端末をネットワーク接続
したいのですが、PINGで相手のIPアドレスを入力しても
繋がりません。
ただし、Windows、Linuxの両方とも自分のIPアドレスで
はPINGがとばせます。
何かアドバイスがあれば教えて下さい。

なお、以下のような環境になっています。
<Windows>
 ・バージョン:WindowsXP SP2
 ・TCP/IPのプロパティ:DHCPにて自動取得
 ・hostsファイルにLinuxのIPアドレス、ホスト名を追加。

<Linux>
 ・バージョン:RedHat9(古いですが)
 ・hostsファイルに以下を追加。
    ・WindowsのIPアドレス、ホスト名。
    ・LinuxのIPアドレス、ホスト名。
 ・IPアドレス      :192.168.XXX.XXX
 ・サブネットマスク   :255.255.255.0
 ・デフォルトゲートウェイ:192.168.XXX.XXX
  (この設定でよいのかわかっていません。)
 ・ifconfigでIPアドレスが表示されるため、
  ネットワークカードは設定できていると思います。

<ネットワーク構成>
 ・WindowsとLinuxをでハブで接続。
 ・WindowsのIEから、\\192.168.XXX.XXX(LinuxのIPアドレス)を
  入力すると、ユーザ名とパスワードを入力させる画面が表示
  される。
  ただし、ユーザ名にroot、パスワードにrootのパスワードを入力
  しても接続できない。
  でも、PINGはとばせない。

以上になります。
長文になってしまい、申し訳ありません。
よろしくお願いします。

投稿日時 - 2007-11-11 22:21:48

QNo.3509880

困ってます

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.2

もしかするとLinux側のファイアウォールでICMPの通信が遮断されているかもしれません。
単純にファイアウォールをOFFにしたいのであれば…

/etc/rc.d/init.d/iptables stop

と打てばファイアウォールは停止します(要root権限)

投稿日時 - 2007-11-15 21:43:28

補足

私がネットワーク設定した手順は以下の通りです。
1./etc/sysconfig/network-scripts/ifcfg-eth0の変更。
  変更内容
   ・BOOTPROTO=dhcpから、BOOTPROTO=static
   ・ONBOOT=noから、ONBOOT=yes
2./etc/sysconfig/networkの変更
  変更内容
   ・GATEWAY=192.168.X.Xを追加。
3./etc/rc.d/init.d/network restartの実行
以上となります。
DNSの指定は、less /etc/resolv.confを実行しても、
resolv.confが空ファイルだったため、
特に設定していません。

投稿日時 - 2007-11-18 22:19:02

お礼

ご回答有難うございます。
また、返答が遅くなり、申し訳ございません。
現在、Windows側からLinuxへ
telnetで接続はできます。
しかし、PINGが飛びません。

教えて頂いたファイアウォール停止コマンドを実行
しましたが、やはりPINGが飛びませんでした。
Telnetができたら、pingもできる訳ではないのですね。

投稿日時 - 2007-11-18 21:46:55

ANo.1

Wr5

> PINGで相手のIPアドレスを入力しても
> 繋がりません。

ICMPのプロトコルフィルタしていんじゃないでしょうか?
ファイアウォールの設定どうなっていますか?
Windowsの方は、ノートンなどを入れていたらそちらの設定を、
標準のままでしたら、[スタート][設定][コントロールパネル][Windowsファイアウォール]で「詳細設定」のICMPのところの「設定」ボタンで、
「エコー要求の着信を許可する」ですかね。
Linuxの方はipcahinsの設定かと。

>  ・WindowsのIEから、\\192.168.XXX.XXX(LinuxのIPアドレス)を
>   入力すると、ユーザ名とパスワードを入力させる画面が表示
>   される。
>   ただし、ユーザ名にroot、パスワードにrootのパスワードを入力
>   しても接続できない。

sambaが正しく設定されていないのでないかと思われます。

投稿日時 - 2007-11-12 00:04:51

お礼

ご回答ありがとうございます。
Windowsは教えていただいた内容が設定されていました。
Linuxについては、ipchainsをネット等で調べてみましたが、
まだどうすればよいのかわかっていません。
もう少し調べてみようと思います。
有難うございました。

投稿日時 - 2007-11-13 22:46:49

あなたにオススメの質問