こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

一部のPCがネット接続できない

ケーブルTVモデムからルータを通してLANケーブルでPC4台につなげていますが、このうち2台がインターネット接続できなくなりました。
うち1台はしばらく前からダメになったのですが使用頻度が低いこともあり、そのうち直そうと思って放置していたのですが、先日メインのPCが使用中に突然メール、ブラウジング、ftpができなくなり、同じ症状となってしまいました。

いろいろ調べてみると問題のPC2台では
・家庭内LANでのWindows NetworkではどのPCとも問題なく接続できる
・LAN内や外部のWWWサーバに対してping ***.***.***.*** は通る
(→したがってネットワークボードやLANケーブルは正常と思われる)

・ルータのケーブル接続先を入れ替えても、ルータを新品に買えてみても症状は変わらない
・ルータのクライアントモニタを見ると問題のPCは接続が認識されている。
・問題のPC以外の2台や無線LAN接続ではこの症状が出ず問題なくネット接続ができる
(→したがってルータの故障とも思われない)

・LAN内や外部のWWWサーバに対してping ***.***.***.*** は通るが、ブラウズhttp://***.***.***.***/ が出来ない(「サーバーが見つからないか、DNSエラーです」が表示される)
・問題のPCはIPadrs、Subnet Mask、Default Gateway、DNSadrsを手動で設定することは出来るが、DHCP自動取得には失敗する。コマンドプロンプトでipconfig /renewを行うと「The following error occured when renewing adapter ローカルエリア接続2:ソケット以外のものに対して操作を実行しようとしました。」のエラー表示が出る

その他の特徴点としては、問題の2台については
・ネットワーク接続名が「ローカルエリア接続2」と「2」の文字がついているが、「新しい接続」を2回設定した覚えはない

などです。PCはいずれも自作で、
 PC1……OS:TurboLinux10、CPU:Pen4/1.4MHz、M/B:P4T AGPPro/4X、Memory:256MB×2、LAN:corega PCI-TXS
 PC2……OS:Win2000Pro/SP4、CPU:Pen4/2.4MHz、M/B:Albatron PX865PE Pro II、Memory:512MB×2、LAN:onboard
 PC3……OS:Win2000Pro/SP4、CPU:Ath64/3500+、M/B:ASUS A8N-SLI SE、Memory:1GB×2、LAN:onboard
 PC4……(すべてPC3と同じ)
問題のPCはPC3とPC4で、メインのPC3はつい先日OSを再インストールしたばかりです。

どなたか解決のヒントでも結構ですので教えていただければ幸いです。どうぞよろしく。

投稿日時 - 2007-11-21 02:29:57

QNo.3535066

困ってます

質問者が選んだベストアンサー

そうですね、以下の情報を補足してもらえないでしょうか?

 ・コントロールパネル→管理ツール→サービス と選択した画面にDHCP Client があると思います。
  それが、開始になっていますか?
 ・接続出来ない問題のPCで、コマンドプロンプト画面ではなくタスクトレイの中のローカルエリア接続2のアイコンの上で右クリックし、「修復」を選択したらどうなりますか?
 ・接続出来ないPCでコマンドプロンプト画面を開き、ipconfig /all を入力したらどのようなネットワークデバイス名が出てきますか?
  (IPアドレスの情報は要りません)
 ・接続出来ない問題のPCに手動設定でIPアドレス周りの情報を設定し、ルーターの管理画面をブラウザで開こうとすると、どうなりますか?

投稿日時 - 2007-11-21 03:03:57

補足

さっそくありがとうございます。情報を補足いたします。

> ・コントロールパネル→管理ツール→サービス と選択した画面にDHCP Client があると思います。
>  それが、開始になっていますか?
→「開始」「自動」になっております。

> ・接続出来ない問題のPCで、コマンドプロンプト画面ではなくタスクトレイの中のローカルエリア接続2のアイコンの上で右クリックし、「修復」を選択したらどうなりますか?
→残念ながら「修復」の項目はありませんでした。

> ・接続出来ないPCでコマンドプロンプト画面を開き、ipconfig /all を入力したらどのようなネットワークデバイス名が出てきますか?
→下記のようになります(念のため全部載せます)。またANo.2さんのアドバイスに従い、異常が無いほうのPCのものも併記します。なお***は伏せ字とさせていただきました。
【接続できないPCのipconfig /all】
Windows 2000 IP Configuration
Host Name . . . . . . . . . . . . : com-4
Primary DNS Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Broadcast
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : ****.**.****.ne.jp
Ethernet adapter ローカル エリア接続 2:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
Physical Address. . . . . . . . . : **-**-**-**-**-**
DHCP Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.100.14
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.100.1
DNS Servers . . . . . . . . . . . : 192.168.100.1

【異常の無いPCのipconfig /all】
Windows 2000 IP Configuration
Host Name . . . . . . . . . . . . : com-2
Primary DNS Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Broadcast
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : ****.**.****.ne.jp
Ethernet adapter ローカル エリア接続:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) PRO/1000 CT Network Connection
Physical Address. . . . . . . . . : **-**-**-**-**-**
DHCP Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.100.12
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.100.1
DNS Servers . . . . . . . . . . . : 192.168.100.1

> ・接続出来ない問題のPCに手動設定でIPアドレス周りの情報を設定し、ルーターの管理画面をブラウザで開こうとすると、どうなりますか?
→http:/192.168.100.1/とするとやはり「ページを表示できません……サーバーが見つからないか、DNSエラーです」が表示されます。

いかがのものでしょう。よろしくお願いいたします。

投稿日時 - 2007-11-21 22:25:20

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(5)

ANo.5

No.2です。
補足ありがとうございます。
直接WANに接続しても同様の現象なのですね。
また、Proxyの設定も問題ないです。

とりあえずは、No.1さんがNo.4で書かれている内容を試されてください。
その結果から、もし何か思い当たることがありましたら、また回答させていただきます。
お役に立てずに申し訳ありません。

投稿日時 - 2007-11-24 17:39:09

お礼

PC修復の時間がなかなかとれず報告が遅れ失礼しました。

さてこの間、お二方のアドバイスにあった点を調べなおしてみたり、無事なPCの方と起動サービスや関連レジストリの比較をしてみたり、PCIネットワークカードを装着したりとて試してみましたが原因の特定や修復はできませんでした。なおオンボードLANのドライバなどは最新のものでした。
ただいろいろ調べるうちに、どうもTCP/IP機能が一部異常になっているらしいことまでは絞り込めました。

そこでWindows2000の修復セットアップを行ったところ、一時的にインターネット接続が復活しました。
しかし完全に復活したわけでなく、IEで「お気に入り」を表示させてみると半分ほどがグレー表示され接続できないという妙な現象が起き、それを調べているうちに数分後にまた突然すべてが接続不可となりました。

この段階でもう修復はあきらめて完全再インストールしたところ、それ以後は問題なく接続できています。
結局原因は不明なままで釈然とはしませんが、とりあえず解決したということで報告させていただきます。
お二方のアドバイスはどちらも参考になりましたので失礼ながら同文のお礼とさせていただきますが、ポイントは回答順につけさせていただきましたのでご了承ください。いろいろありがとうございました。

投稿日時 - 2007-12-02 23:23:23

ANo.4

設定その他におかしな点は見られないので、

 ・PC3は再インストールした直後から同じ状況だったのか?

という点が気になる。
もしも再インストール直後は正常に接続できていたというなら、悪意のあるソフトの侵入を疑う必要がある。→ケースA
再インストール直後から駄目なら、ハード側の問題を疑う必要がある。→ケースB

【ケースAの場合】
 PC3をもう一度クリーンインストールする。
 他のPCが感染源の可能性も考慮し、セキュリティソフトのセットアップやWindowsUpdateが終了するまで他のPCはルーターから外しておく。

【ケースBの場合】
 まず、LANのドライバがマザーボードのサポートページで公開されている最新版かか確認し、最新版で無いなら更新して様子を見てみる。
 最新版にしても状況が変わらないようなら、外付けのLANカード(PCIバスのタイプなら千円もしない)を購入してそれを取り付けてみる。

投稿日時 - 2007-11-22 13:09:12

補足

たびたびありがとうございます。

> ・PC3は再インストールした直後から同じ状況だったのか?
→再インストール後1週間ほどは問題なく動作していたのですが、使用中突然接続不良になったものです。

> 【ケースAの場合】
> PC3をもう一度クリーンインストールする。
→そうですね、またインストールし直しというのも気が重いけれど、最後はそれしかありませんね。今回確かにケーブルを接続したままインストールしていました。次回は気をつけようと思います。

> 【ケースBの場合】
→念のためドライバのバージョンを確かめてみます。また、PCIバス用LANカードが余っているので、これも試してみます。

なお事情により、以降の補足やお礼の書き込みは連休明けまで出来なくなりますのでご了承下さい。申し訳ありません。結果が出たら必ずお礼欄で報告させていただきますのでどうぞよろしく。

投稿日時 - 2007-11-22 18:45:44

お礼

PC修復の時間がなかなかとれず報告が遅れ失礼しました。

さてこの間、お二方のアドバイスにあった点を調べなおしてみたり、無事なPCの方と起動サービスや関連レジストリの比較をしてみたり、PCIネットワークカードを装着したりとて試してみましたが原因の特定や修復はできませんでした。なおオンボードLANのドライバなどは最新のものでした。
ただいろいろ調べるうちに、どうもTCP/IP機能が一部異常になっているらしいことまでは絞り込めました。

そこでWindows2000の修復セットアップを行ったところ、一時的にインターネット接続が復活しました。
しかし完全に復活したわけでなく、IEで「お気に入り」を表示させてみると半分ほどがグレー表示され接続できないという妙な現象が起き、それを調べているうちに数分後にまた突然すべてが接続不可となりました。

この段階でもう修復はあきらめて完全再インストールしたところ、それ以後は問題なく接続できています。
結局原因は不明なままで釈然とはしませんが、とりあえず解決したということで報告させていただきます。
お二方のアドバイスはどちらも参考になりましたので失礼ながら同文のお礼とさせていただきますが、ポイントは回答順につけさせていただきましたのでご了承ください。いろいろありがとうございました。

投稿日時 - 2007-12-02 23:22:56

ANo.3

No.2です。
ipconfig /all の内容を拝見しました。
正常なPCと比べてみて、特に問題となりそうなところはなさそうですね…。
WEBブラウザからルータのIPアドレス指定で管理画面も開けないとなると、
ただ名前解決ができないというわけでもないのかもしれません。

ちなみにWEBブラウザはProxyの設定をされていたりしますか?
Proxyの設定をされている場合は、Proxyなしでの接続も試されてみてください。
また、異常のあるPCをルーター経由ではなく、DHCPによるIPアドレスの自動取得で直接WANに接続した場合も同様の現象が発生しますか?

投稿日時 - 2007-11-22 00:35:03

補足

たびたびありがとうございます。補足いたします。

> ちなみにWEBブラウザはProxyの設定を……
→「プロキシサーバの自動検出(推奨)」に設定しております。Proxyを使っているのかどうか、よく判りません。

> ……直接WANに接続した場合も同様の現象が発生しますか?
→モデムに直結してやってみましたが変わりませんでした。ipconfig /allの表示内容もルータ経由の場合と同じで、下記の通りでした。
【IPアドレス自動取得に設定した場合のipconfig】
Windows 2000 IP Configuration
Host Name . . . . . . . . . . . . : com-3
Primary DNS Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Broadcast
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
Ethernet adapter ローカル エリア接続 2:
Connection-specific DNS Suffix . : ****.**.****.ne.jp
Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
Physical Address. . . . . . . . . : *-**-**-**-**-**
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.12.19
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . :

質問にも述べましたとおり、使用中に突然ネット接続が出来なくなったのが解せないところですが……。
他にもお心当たりがありましたら、よろしくお願いいたします。

投稿日時 - 2007-11-22 10:46:14

ANo.2

こんばんは。
名前解決ができていないだけのようなので、単なる設定誤りのようにも思えるのですが
手動で設定をされた場合の情報は、他の正常に接続できる端末と同様になっていたのですよね?
ipconfig /allで表示される情報を、正常な端末と、そうでない端末で比べてみてはどうでしょうか。

また、DHCPによるIPアドレスの自動取得失敗に関して、以下のような記事があります。
http://support.microsoft.com/kb/817571/ja
手動で設定してもだめ、ということなので関係ないかもしれませんが…。

お役に立てれば幸いです。

投稿日時 - 2007-11-21 03:11:35

お礼

早々のご回答ありがとうございます。
アドバイスに従い、正常なほうのPCとのipconfigを比較してみました(ANo.1の方への補足をご参照ください)。
ipconfigでは問題は見つけられなかったのですが、「正常なPCとの比較」というのは良いアドバイスをいただけました。ほかの点でも徹底的に比較して問題点を探してみようと思います。

またサポート記事の紹介も助かります。何か関係することがあるかもしれないのでよく読んでチェックしてみようと思います。ありがとうございました。

投稿日時 - 2007-11-21 22:41:20

あなたにオススメの質問