こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

ネットワークに繋がらない

再起動後突然インターネット、およびネットワークとの疎通が取れなくなりました。
マシン環境は下記のようになります。

CPU:Athlon XP 3800+
Mem:1024MB
MB :A8V
電源:500W
OS :Windows XP Professional

原因がわからず、アンチウイルスソフト・ファイアウォールも
導入していなかったため、ウイルスかなとOSの再インストールを行いました。
けれど、ネット接続ができません。
OS再インストールもPC自作も過去に何度か経験しているのですが
このような事が起きたことが無くとまどっています。
今まで問題なく使えていて、LANで繋がっているPCは問題なくインターネットに繋がります。
回線は光でネットワーク構成は下記のようです。

[電話回線]→[モデム?]→[port1]→[PC1](問題PC)

        [port2]→[PC2](ネットに問題なく繋がっている)

今まで試した事を書きます。
1.OS再インストール
2.マザー付属ドライバCDインストール
3.コンパネ→ネットワーク接続→新しい接続を作成する
 →ホームネットワークや小規模オフィスのネットワークをセットアップする
4.「ネットワークハードウェアを検出できません。ネットワークカード、ケーブル、およびデバイスドライバをインストールし構成する必要があります。」と表示される
5.マイコンピュータ→プロパティ→ハードウェア→デバイスマネージャ
 を見てみると、ネットワークアダプタの欄が無い。その他のデバイスにイーサネットコントローラがあるがこれが原因か?→でもオンボードLANを使用している…。
6.コマンドプロンプトでipconfig実施→「Windows IP Configuration」とだけ表示される
7.コマンドプロンプトで「route print」実施→127.0.0.0のループバックだけ表示される
8.コマンドプロンプトで「ping localhost」実施→疎通
9.コマンドプロンプトで「ping 192.168.1.2(PC2)」実施→未疎通

以上のような感じです。
LANカードを購入すれば繋がりますかね?
というか、オンボードのLANのみ壊れる事ってあるんですかね…。
どなたか何かヒントでもあればご教授頂ければと思います。
よろしくお願い致します。

投稿日時 - 2008-04-08 09:50:56

QNo.3931622

すぐに回答ほしいです

質問者が選んだベストアンサー

>その他のデバイスにイーサネットコントローラがある
突然の不具合ということで故障もあるかもしれませんが、
正しいドライバがあたっていないときの症状とおなじですので、
とりあえずドライバの更新をしてみてはどうでしょうか。

手順としては、
デバイスマネージャからいったん削除して再起動。
起動時に自動的にハードウェアウィザードで検出されたらいったんキャンセル。
メーカーHPからインストーラ形式のLANドライバをダウンロードしてインストール。

どうしても駄目なら増設でしょう。

投稿日時 - 2008-04-08 10:35:43

補足

すいません、ドライバを入れたつもりになっていただけでした。
ドライバをマザー付属CD-ROMから入れたところ、デバイスマネージャに
ネットワークアダプタとして認識されました。
しかし、下の補足のような現状となっております。

投稿日時 - 2008-04-08 11:13:32

このQ&Aは役に立ちましたか?

3人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.4

IRQの競合はあくまでも例であげただけで、PCIデバイスを使っていればほぼ無いはず。正常に動作していない原因がわかることもあります、ということを言いたかっただけです。

>pingループバック可能→NIC生きてる
pingループバックではNICが生きていることは確認できませんよ。
WindowsでTCP/IPが正常にバインドされていることが確認できるだけです。

>LANインタフェースにケーブルを刺す→刺さってないと言われる
他の方への回答から、現在生きているケーブルを挿しても挿されてないことになってるんですよね。ということは、モデムのポート側やケーブルの障害の可能性は排除できてますから、NICのポートのハードエラーの可能性が大ですね。

>…そんなことあるのかなぁ…
ありますよ。
たとえば、インターフェースの中のピンが一本折れた状態になってる時とか、Windows上ではNICは正常に動作してますが、ケーブルを挿しても認識はしてくれなくなります。

投稿日時 - 2008-04-08 12:01:40

補足

たびたびのご返信ありがとうございます。

なるほど、勉強になります。やはりNICの接続口が壊れた可能性が高いですかね。
説明不足でしたが、そんなことあるのかなぁと思ったのは、ネットに繋がっている状態から再起動しただけで繋がらなくなったというのが根本だったので疑問に思いました。

なんにしろ、NICを買ってからまた報告させて頂きます。もしこれが原因じゃなくても、いずれNICはethを二つ搭載する予定があったので無駄にはなりませんし。

投稿日時 - 2008-04-08 12:43:46

お礼

皆様ご回答ありがとうございました。
LANカードを購入し、取り付けることによりすんなりとネットに繋がりました。
こんな事ってあるんだって事や、この記事への回答を見て勉強させて頂きました。
ありがとうございました。

投稿日時 - 2008-04-08 23:40:28

ANo.3

5を見ると、NICのドライバが正常に動いてないようですね。
MBのメーカーサイトからNICのドライバをDLしてインストールしてみてはいかがでしょう?
あと、その他のデバイスに表示されているNICのプロパティはどうなってますか?そこに解決のヒントがある場合もありますよ。(IRQの競合とか)
あとは、BIOS設定で初期状態に戻すと直ったりとか。

投稿日時 - 2008-04-08 10:40:40

補足

NICのドライバはたんなる入れ忘れだったみたいです。
IRQの競合ってまだする事ってあるんですか…?
BIOS設定はBootデバイスぐらいしかいじってないです。
安いしNIC購入が手っ取り早いのかもしれません。
けどそれで解決しなかったら原因がわかりません…。
現状として
pingループバック可能→NIC生きてる
LANインタフェースにケーブルを刺す→刺さってないと言われる
という事はLANインタフェースのみ壊れてるように思えますが…そんなことあるのかなぁ…

投稿日時 - 2008-04-08 11:15:04

ANo.1

うーむ、その症状だとLANボードが怪しいですね。
認識してないようですし。。。。
LANカードを増設すればokのような気がします。
「オンボードのLANのみ壊れる事ってあるんですかね」ありますよw
私も最近USBが使えなくなり、ボードを増設して使ってますから。
2000円以下なので、気にしてませんがねw

投稿日時 - 2008-04-08 09:58:46

補足

オンボードLAN自体はたんにドライバの入れ忘れが発覚しました。
ですが、LANケーブルが刺さっていません…と怒られます。
PC2で使用している正常動作しているLANケーブルをさしてもだめなので
オンボードのLANのインターフェースが壊れているのが原因のように思えます。
今日LANカードを買ってきてみようと思います。

投稿日時 - 2008-04-08 11:10:10

あなたにオススメの質問