こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

DISK BOOT FAILUREのメッセージ

PCショップのデスクトップPC(WindowsXP HOME)に最近HDDを増設しました。その後、セッティングミスで起動できなかったのですが、なんとか起動することができました。起動時にDISK BOOT FAILURE,INSERT SYSTEM DISK AND PRESS ENTERのメッセージが出るのでXPのCD-ROMを入れるとすんなり起動しますが、入っていないと起動しません。いろいろ調べ、XPの修復をしようと思いますが、既にSP3をインストールしており、できません。HDDを増設したので、OSの入ったHDDを最初に読み込まないからかな、と思いますが、なにぶん素人なのでわかりません。ご教示願います。

投稿日時 - 2008-11-07 13:01:16

QNo.4460137

すぐに回答ほしいです

質問者が選んだベストアンサー

かなり前のM/Bですね。No.3への書き込みから推察するに、IDEを2発搭載していらっしゃるのでしょうか。

申し訳ありませんが、私はこの時代にはAMDユーザーでしたので、この板について詳細な知識を持ち合わせておりません。

1点だけ補足しますと、この頃のM/BにはジャンパのMaster/Slave設定よりもケーブルセレクト設定を優先認識するモデルがあるようです
(あくまでも経験上の感想でして、本来はプロとしてこんな事を申し上げてはいけないのでしょうが・・・)。

当然ですが、IDE/SATA HDD混在の場合は話が変わります。
この場合は下記リンクのマニュアル 3-18をご参照下さい。
http://www.msi-computer.co.jp/manual/865M2/865PEM2_865GM2-3J.zip

投稿日時 - 2008-11-07 16:21:51

お礼

BIOSの設定で解決しました。「Hard Disk Boot Priority」の順位で、OSの入ったHDDが2番目になっていました。マニュアル大変参考になりました。ありがとうございました。

投稿日時 - 2008-11-08 18:29:13

このQ&Aは役に立ちましたか?

6人が「このQ&Aが役に立った」と投票しています

回答(7)

ANo.7

>起動時にDISK BOOT FAILURE,INSERT SYSTEM DISK AND PRESS ENTERのメッセージが出るのでXPのCD-ROMを入れるとすんなり起動しますが、入っていないと起動しません。

OSの入った起動ディスク(HDD)がないって言ってるので増設した
HDDから起動するよう設定されてます。
HDDを複数搭載するときは、セオリー通りIDE0(1)にHDDでマスターが
OSが入っているHDD,スレーブが増設HDD、IDE1(2)に光学ドライブが
基本です。

BIOSの設定がよく分からないなら、デフォルトにすればHDDが
自動的にIDE0(1)プライマリのマスターから起動できるようになります。
BIOSでIDEのプライマリーを0又は1と表現する場合があります。

>XPのCD-ROMを入れるとすんなり起動しますが、入っていないと起動しません。

これは、OSのインストールが始まるので「起動する」って
意味ですよね?

投稿日時 - 2008-11-08 07:58:08

お礼

BIOSの設定で無事解決いたしました。ありがとうございました。OSのインストールは始まらず、すんなり通常どおり起動する状態でした。ちなみに、デフォルトをしてみましたが、それ以降起動時の一番最初に「MSI」の画面が出るようになりました。 

投稿日時 - 2008-11-08 18:37:37

ANo.6

BIOSのBOOTのところで起動順位がどうなっているか確認してください。

状況からみて1番に光学ディスク、2番にOSの入っていない方のHDDを読みに行っているのではないですか。

HDDの名前(型式)が書かれていると思いますので、OSの入っているHDDの名前が一番初めにくるように設定し直してみてください。

投稿日時 - 2008-11-07 21:42:52

お礼

おっしゃる通りでした。おかげで無事解決いたしました。ありがとうございました。

投稿日時 - 2008-11-08 18:32:26

ANo.5

ANo.1=ANo.4です。
肝腎な事をかきこんでいませんでした。

要するに
両方の HDD Jumper Settings>CS ,だめならば片方ずつCSにしてみる

これで改善する事例が結構あるんですよ。
違ったらご免なさい。

投稿日時 - 2008-11-07 16:48:13

お礼

無事解決しました。ありがとうございました。

投稿日時 - 2008-11-08 18:29:49

ANo.3

もしIDEのHDDなら、ジャンパピン設定じゃないでしょうか?
初めから搭載されていたHDDをマスター、増設した方のHDDをスレーブに変えてみて下さい。
ケーブルのマスター、スレーブが解るならケーブルセレクトでもOKです。

参考URL:http://pcrescue.easter.ne.jp/pc_hdd03.htm

投稿日時 - 2008-11-07 14:53:15

お礼

ジャンパピンの設定は従来のHDDをマスター、増設した方のHDDをスレーブにしています。XPのCD-ROMから起動でき、その後はなんの不都合もなく使用できます。ケーブルセレクトについては理解できました。試してみます。ありがとうございました。

投稿日時 - 2008-11-07 15:38:33

ANo.2

BIOS設定が必要かも??

2台HDがあるので、OSの入っていないHDを先に
読みに行ってる可能性ありですね。

投稿日時 - 2008-11-07 14:38:35

お礼

ありがとうございます。
BIOS設定については不勉強で、よくわかりませんが、皆さんのご意見を参考に挑戦したいと思います。

投稿日時 - 2008-11-07 15:33:57

ANo.1

マザーボード名が分かれば、BIOS設定をお調べします。

投稿日時 - 2008-11-07 13:52:47

お礼

情報が不足しておりすみませんでした。
マザーボードは MSI 865GM2 です。

投稿日時 - 2008-11-07 15:32:21

あなたにオススメの質問