こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

BIOSアップデート後のRAID不具合?(長文です)

ASUSのサイトより、BIOSデータをダウンロードし、
ASUS UPDATEというアプリを使って、BIOSを1013から1102へアップデート致しました。

元々、内蔵HD2台をRAID1で使用していたのですが、
アップデート後、再起動するとWindowsが起動せず。。。
RAIDの設定が無くなっているのかと思い、BIOS画面にて設定するも、
『windows root\system32\hal.dll.が壊れているか存在しないため起動できません』という旨が表示され起動せず。。。
試しに”IDE”と設定すると起動はしましたが、起動直後に『Windows Error! C0000013 764cbf9c 4 764cbf9c 4 ・・・ 再試行/続行/キャンセル』というウィンドウが立ち上がるようになってしまいました。
ウィンドウをキャンセルすると大丈夫といえば大丈夫ですが、
当然、今までRAID1で設定していた際には見えなかったローカルディスクEが見える始末・・・。
ちなみに、HD内のデータは無事でしたので、既にバックアップはとってあります。


そもそもアップデートしたのには理由がありまして、
以前からUSBデバイスといいますか、USB端子に差し込んでいる機器との通信が一時的に途絶えるような症状がありました。
具体的には、USB接続のワイヤレスマウスを使用中、ファイルをドラッグ&ドロップしようとすると、
クリックが外れて思いもよらない箇所にファイルが移動したり、
USBフラッシュメモリをずっと挿した状態であるにも関わらず、
突然『リムーバブルディスク(○) Windowsが実行する動作を選んでください』のウィンドウが立ち上がったり、
『さらに高速に接続出来るデバイス』??のようなポップアップが表示されたりされなかったり(USB機器の抜き差しはしていません)と…
どうもUSBまわりがおかしかったのでネットを検索してみたところ、
同じマザーボードを使っている方がBIOSアップデートで改善されたという記事を載せていらっしゃるのを発見し、
アップデートを試んでみたという次第です。


結局は、USBまわりの問題は解決されず、後には非常に動きがおかしくなってRAID1設定も無い状態という状況だけが残ってしまいました。


長くなってしまいましたが、このような場合の対処方がお分かりになる方がいらっしゃいますでしょうか?
大変お手数ですが、何卒宜しくお願い致します。

------------------------------------
■Windows XP SP2
■マザーボード:ASUS P5K-E
■CPU:Intel Core2 Quad Q6600
■メモリ:4GB
■内蔵160GBハードディスク×2台

投稿日時 - 2008-12-02 22:07:32

QNo.4525069

すぐに回答ほしいです

質問者が選んだベストアンサー

RAIDのことは詳しくありません。
しかし、よくそのトラブルで、HDDが異常がなくて
よかったと思います。

よくあるトラブルは、サルベージできなくなることです。
こうなると、お手上げです。

なので、RAIDは嫌いです。使う気がしません。

■Windows XP SP2
■マザーボード:ASUS P5E-V
■CPU:Intel Core2 Duo E8400
■メモリ:4GB
■内蔵1TBハードディスク×2台

です。
C:\WinXP(1TB)
D:\WinXP(1TB)

C:\とD:\ミラーリングしてあります。
BIOSで切り替えます。

RAIDではありません。

次にUSBの件ですが、USB機器は、
デバイスドライバーをインストールした場所から
動かさないようにしてください。

USB2.0の”やどかり性”のためです。

投稿日時 - 2008-12-02 23:29:47

お礼

そうそうのご回答を頂いておきながら、お礼が遅くなってしまい申し訳御座いません!!

お陰様で、無事復旧致しました!

> USB2.0の”やどかり性”のためです。

なるほど・・・確かにそれは有り得ますね。。。
大変勉強になります。有難う御座います。
また質問させて頂く事もありましたら、その際もお力を貸して頂けましたら幸いです。

投稿日時 - 2008-12-07 02:23:09

このQ&Aは役に立ちましたか?

2人が「このQ&Aが役に立った」と投票しています

回答(3)

ANo.3

一概になんとも言えませんが、
BIOSのCMOSクリアして再度RAIDを組みなおしてみたらいかがでしょう?

おそらく2本のHDDと言うことなのでミラーリングかと思いますが、ミラーリンクであれば1本でも起動するのでフルバックアップを取り、アレイを組みなおしてリストアすれば問題ないのかと思います。

ただUSBの問題はOSの問題も考えられなくもないのでOSのCDから入れなおしたほうが無難な気がします。

投稿日時 - 2008-12-05 21:13:41

お礼

お礼が遅くなってしまい申し訳御座いません!!
No.1の方、No.2の方へのお礼にも書かせて頂きました通り、
お陰様で、無事復旧致しました!

USBの問題は、OSに原因がある場合も考えられるのですね・・・
お陰様で今のところUSBの問題も解決された??ようですので、
近々に同じ現象が起きた場合にはOS再インストールも考えてみようと思います。

また質問させて頂く事もあるかと思いますので、その際もお力を貸して頂けましたら幸いです。

投稿日時 - 2008-12-07 02:45:15

ANo.2

まず根本的な事からアップデートするとBIOS設定は初期化されます。
それと単騎でOS起動したら、RAID1は組みなおしになると思います。
BIOSアップデート自体でRAIDアレイは壊れないです。
BIOSアップデートに失敗したら別ですが
正直、詳しくない方がBIOSアップデートに手を出すのは自殺行為
アップデート前に、BIOS設定を記録しておくべきです。

どういったRAIDコントローラーつかっているか分からないですが
RAID情報は、HDDにありますので正常でしたら
ディスクの管理ツールからインポートすることで、読み込むことができるようになると思います。(RAID0, RAID1共に)

後、USBですが沢山USBのデバイスを使用してませんか?
使用できる電気的容量がUSB1ポート辺り500mlAです。
それを越えると電圧降下を起こして不安定になります。
後は、ポートが埃を被ってリークしてるとか
接触不良も考えられます、接点復活のアルコール系スプレーで
端子を清掃するって手も、コンセントから抜いた状態で

投稿日時 - 2008-12-03 08:44:52

お礼

そうそうのご回答を頂いておきながら、お礼が遅くなってしまい申し訳御座いません!!

お陰様で、無事復旧致しました!

過去にはHD一台のみのPCを使っておりまして、その際には数回BIOSアップデートを行った事がありますが、
RAID構成でのアップデートは初めてでして。。。

結局は今回、
ローカルディスクC(元々SATAポート1に接続)を取り外し、
ローカルディスクE(元々SATAポート2に接続)だけをマザーボードSATAポート1に接続→
BIOS設定をRAIDに変更→
Windows XP起動→
Intel Matrix Storage ManagerがHDの異常を感知(HDが一台しか接続されていない為)→
ローカルディスクCをSATAポート2に接続→
Windows XP起動→
Intel Matrix Storage ManagerがHDを自動復旧(ローカルディスクEのデータをCドライブにコピー)

・・・という流れで復旧致しました。
BIOSも無事アップデートされており、今のところUSBまわりのポップアップ等も表示されておりません。

恐らく・・・アップデート後に再起動する際に何らかの不備があったのではないかと。。。
はっきりとした原因は分かっておりませんが、
とにかく皆様のお知恵をお貸し頂き、大変感謝しております。

併せて、接点復活スプレーにてUSBポートの掃除も致しました。

また質問させて頂く事もありましたら、その際もお力を貸して頂けましたら幸いです。

投稿日時 - 2008-12-07 02:41:15

あなたにオススメの質問