こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

一部にJavaScriptを使ったホームページの表示の不具合について

ホームページビルダー(ver13)にてホームページを制作し、ページの一部分にJava Scriptにて画像の表示をするようにしまた。
ホームページビルダーのプレビューの画面と,デスクトップ上にてインターネットエクスプローラーではちゃんと表示されるのですが、実際にインターネットで開いたときに3枚の画像を順番に表示するところを、1枚しか表示できません。どのような原因が考えられますか。宜しくお願いいたします。

投稿日時 - 2009-04-28 19:44:38

QNo.4916304

困ってます

質問者が選んだベストアンサー

>ネット上からのJavaScriptサンプルに対し(コピーし)、ホームページUP用のファイルの中で画像のみ表示したい画像を同じ品番にして入れ替え試してみました。

⇒画像ファイル名は半角英数字で書かれているでしょうか?

>最初に編集画面で貼り付けを行った際にエラー表示が出ましたので、エラーが出ないようには修正し確認しました。

⇒修正前(コピーしたままの元の状態)のJavaScriptは、ローカル(UPする前のご自分のPC内)の環境で動作確認されましたか?

>後から、気になった事はホームページ掲載サイトがCGI不可となってますが、この部分でひっかかるのでしょうか。

⇒JavaScriptで画像を順番に表示させるだけですよね?ユーザが画像をアップロードするとか、そういう使用でなければCGIとはあまり関係ないと思います。

ちなみに、そのJavaScript以外に別のJavaScriptやJSファイルを使用していませんか?
中身によりますがJavaScriptが混在しているとエラーの原因となり、正しく動作しないことも考えられます。
レンタルサーバーなどではUP後に自動でJavaScriptで広告を入れていることもあります。一度確認してみたください。
また、いろいろ試してもうまく行かない場合には、同じような動作が実現可能な別のJavaScriptのサンプルなどを書き換えてお試しになってはいかがでしょうか。

投稿日時 - 2009-05-02 17:34:11

お礼

早速の回答どうも有難うございます。
回答頂いた件で思い当たるところがありました。
画像ファイル名でスペースが入っているところが半角のスペースになっていませんでした。(スペース分のみ全角)
それとサンプルページの広告もあてはまっています。
気になったCGIの件も、すこしすっきりしました。
もう一度整理して、確認してみます。
どうも有難うございました。

投稿日時 - 2009-05-02 20:40:32

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.1

失礼ですが、
「13cmのトンカチで三脚を作り、三脚の一部に釘を打って立つように仕上げました。
工場で確認したらちゃんと立ってたのですが、実際使用すると3本の足がちゃんと支えるところを、1本しか支えてくれません。どのような原因が考えられますか。宜しくお願いいたします。」
この質問に答えられますか?

どのようなHTMLに、どのようなJavaScriptですか?
画像はちゃんとUPしていますか?
ファイル名はあっていますか?
IE以外のブラウザでは確認されましたか?

投稿日時 - 2009-04-30 01:45:28

補足

説明不足でわかりずらい質問に、回答して頂き有難うございます。
素人で説明がうまくできませんが、ネット上からのJavaScriptサンプルに対し(コピーし)、ホームページUP用のファイルの中で画像のみ表示したい画像を同じ品番にして入れ替え試してみました。
そこで、ホームページビルダーでプレビューの画面で表示の確認をしました。ただ、最初に編集画面で貼り付けを行った際にエラー表示が出ましたので、エラーが出ないようには修正し確認しました。
後から、気になった事はホームページ掲載サイトがCGI不可となってますが、この部分でひっかかるのでしょうか。

投稿日時 - 2009-05-02 12:51:29

あなたにオススメの質問