こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

I/Oデバイスエラーと大容量HDD

OS:WIN XP Pro SP1は適用していません
M/B:GA-7VAXP 
HDD:MAXTOR 6Y160PO 160GB NTFSフォーマット
メモリ:DDR-333 256MB
CPU:Athlon1100 

症状:48ビットLBAを有効にし上記HDDにパーティションを1つ作成しNTFSフォーマットした。
そして動画を問題のHDDに別ドライブから
コピーしたが、その動画をWindowsMediaPlayerにて見ると途中でI/Oデバイスエラーというメッセージが表示され動画が中断される。

BIOSは購入時のまま手を加えておらず、LBA48に対応しているとWEBサイトにもありました。

では、何が問題でこのような症状が発生するのか?
そしてこの解決法を教えてください。
なるべくパーティションは1つ。160GBまるごと使いたいです。
よろしくおねがいします。

投稿日時 - 2003-05-11 18:25:22

QNo.544836

すぐに回答ほしいです

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.2

#1です。
質問文を理解できていませんでした。
ごめんなさい。

SP1適用済みインストールCDの作成方法の資料が出てきたのですが、あまりに長くて複雑なので、WEBから検索しました。

結構ありました。


I/Oエラーについては不明ですが、IDE周りのエラーかと…。

http://www7.plala.or.jp/chemnpus/xpsp1.html

http://www5b.biglobe.ne.jp/~oh_lavie/etc/spboot.htm

http://www.atmarkit.co.jp/fwin2k/insiderseye/20020921xpsp1/xpsp1_02.html

投稿日時 - 2003-05-11 20:10:35

補足

―――――
追加報告
―――――
 問題のドライブを126GB(137GB以下)でパーティションを区切り運用してみました。
すると質問にあるのと同様の操作にて
WindowsMediaPlayerのエラーメッセージ「ファンクションが間違ってます」が表示されました。
別のドライブではこのエラーは発生しませんでした。
 こうなってくると48ビットLBAあたりの問題ではないのかもしれません。
デバイスマネージャには異常が見受けられず
リソースの競合も発生しているとはなっておりません。ひとつ気がかりなのは、Cドライブと論理ドライブD以外のドライブがIDEなのにもかかわらずSCSIとして
認識されてしまっていることですがこれは異常なのでしょうか?今まではこれでも何の異常もなかったのですが…

投稿日時 - 2003-05-11 21:01:08

お礼

ですから、
SP1適用済みインストールCDの作成方法は
把握しているんですよ。
結局、問題は解決しませんでした。

投稿日時 - 2003-05-20 20:31:46

ANo.1

KT400マシンは48ビットLBAのIDEドライバがあるの?

IntelチップセットならIAAとかのドライバを入れる事で可能になりますが…。

あと、WindowsXP SP1を適用したとしてもデフォルトでは137GBオーバーは有効になってません。
レジストリエディタで
「HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Parameters」のキーを開き
「EnableBigLba」というDWORD値を作成
値に「1」を入力すれば有効になります。

1パーテーションで137GBオーバーはSP1適用済みのXPをインストールする必要があると思いますよ?

SP1適用済みブートディスクを作成する事になりますが手順を忘れてしまいました。御免なさい。

投稿日時 - 2003-05-11 18:50:31

補足

>あと、WindowsXP SP1を適用したとしてもデフォルト>では137GBオーバーは有効になってません。
>レジストリエディタで
>「HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Ser>vices\atapi\Parameters」のキーを開き
>「EnableBigLba」というDWORD値を作成
>値に「1」を入力すれば有効になります。

48ビットLBAを有効にしたというのは上記の作業を指しています。そしてその作業についてはすでに行いました。

>KT400マシンは48ビットLBAのIDEドライバがある
>の?

対応しているはずです。

>1パーテーションで137GBオーバーはSP1適用済みのXP>をインストールする必要があると思いますよ

どうやらそうみたいですね。ただSP1もしくはSP1aを適用するだけじゃダメなんですか。面倒だな。

>SP1適用済みブートディスクを作成する事になります>が手順を忘れてしまいました。御免なさい。

いえいえ、質問に回答していただいただけでも十分です。その手順は把握しております。

――――――――――
質問補足
――――――――――
私はまず、48ビットLBAを有効にせずに問題のHDDを
運用していました。その際はファイル自体開くことができず、プログラムが応答しない状態に陥りました。

次に48ビットLBAを有効にして問題のHDDを運用するとプログラムが応答しない問題は解決しました。
しかし、I/Oエラーが発生するようになりました。

つまりこの問題を私は解決したいんですが、
サービスパックを適用済みXPをインストールする以外に解決法はありませんか?
そしてI/Oエラー発生の原因はサービスパックを適用済みXPをインストールしていないということ以外にありませんか?

では、どなたか解説よろしく。

投稿日時 - 2003-05-11 19:24:32

お礼

>パーテーションで137GBオーバーはSP1適用済みのXPをインストールする必要があると思いますよ?

そのようでした。microsoftWEBサイト内で調べてみるとSP1適用なしで、この作業を行うのは不可能とのことでした。

投稿日時 - 2003-05-20 20:35:29

あなたにオススメの質問