こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

回答欄にURLがうまく貼れません

回答欄にURLがうまく貼れません

先日、教えて!goo で回答したのですが、回答欄に貼ったURLが途中までしか有効にならず、目的のページが開けませんでした。それ自体は大して重要な参考URLでもないので騒ぐのも気が引けるのですが、原因を知りたく思い、質問させていただきます。

私が貼りたかったのはwikipediaのあるページの中の一項目へ直接飛ぶURLなのです↓
http://fr.wikipedia.org/wiki/Panth%C3%A9on_(Paris)#Les_femmes_au_Panth.C3.A9on
しかし(Paris)以下が無効になりました。

長すぎたのかと思って回答を重ねてページそのもののURLを貼ったところ↓
http://fr.wikipedia.org/wiki/Panth%C3%A9on_(Paris)
やはり(Paris)以下が無効になり、全く別のページ(wikiの同名異項)にリンクしてしまいました。

2度とも、回答を投稿する前の確認欄では問題なく、目的のページを開くことができました。

これはどこに問題があったのでしょうか。
参考URL欄ではなく回答欄に直接貼ったのがいけなかったのかとも思いますが、私のパソコンに何か問題がある可能性もあるのでしょうか。

その質問/回答自体はこちらです↓
http://okwave.jp/qa/q5846754.html

なにかお心当たりのある方の回答をお待ち申し上げております。

投稿日時 - 2010-04-26 17:07:30

QNo.5853009

暇なときに回答ください

質問者が選んだベストアンサー

詳しくないし、正確にはわかっていないのですが。

URLに使えない文字というのが結構あって、その文字を記述したい時は%と16進数文字で
表すことになっています。
Webブラウザのアドレス欄に貼る際は問題ないので気付きにくいです。

ここのQAに URL を書くと、URLである事を認識してリンクを張りアンダーバーが付きますが、
この「URL と判定する際」に
先のルールに影響されてるようです。

添付図はいずれもURLです。(長いので先頭の
http://en.wikipedia.org/ あたりまで省略 )

1 解答欄に貼り付けた文字
2 [確認する]クリック後 ( URL 判定後 )
3 QAサイトが抽出した「リンク先」

4~6、7~9 も同様(4,7が 解答欄に貼り付けたものです )

1~3を見ると、
Panth?on
の6番目の文字コードが問題あるようです。16進コードが%C3%A9で、
ASCII8bit文字でないコードで、直接貼り付けていけない文字らしく
「URL の判定」でもここで切られています。

4~6は、 ? が %C3%A9 に置換されたもので、この部分は問題なくなったようです。

質問文
http://fr.wikipedia.org/wiki/Panth%C3%A9on_(Paris)#Les_femmes_au_Panth.C3.A9on
>しかし(Paris)以下が無効になりました。
とありますが、質問文中ではちゃんとリンクされてます。
では元ネタを見ると
>現在のところマリー・キュリーと二人しかいないんですね↓
http://en.wikipedia.org/wiki/Panth%C3%A9on,_Paris#Full_list_of_people_interred

と、Panth?onの次に ","(カンマ)がありますがこれはオリジナルにはなかったのでは?
Webブラウザではカンマがあっても削除してもリンク先を開けるので無視されてるようですが、
QAサイトの「URL認識」ではここで切られてます。

( なども16進文字に置換しないといけないようですが、
今回のトラブルには関わってないようなので触れないでおきます。

投稿日時 - 2010-04-26 18:46:27

お礼

丁寧な御説明、ありがとうございます。
おおっ!!
アドレス貼りつけがこんなに奥深いものとは・・・!!
気軽に質問を立てたので、ありがたくフムフム・・・と読みながらも、実は(おそらく)根本を理解していないパソコン原始人です。

実はのっけから、
>その文字を記述したい時は%と16進数文字で表すことになっています。
を拝読して「そうだったのか!」と知識を蓄えた自己満足に陥ってしまいました。

回答者さまのお立場からすれば、なんとも教えがいのない質問者ですが、今後同じようなトラブルに遭遇した時は再度このページを開いて、同じ手順で確認をしてみるつもりです。

投稿日時 - 2010-05-08 01:48:59

このQ&Aは役に立ちましたか?

24人が「このQ&Aが役に立った」と投票しています

回答(3)

ANo.3

No.1,2です。

No.1>QAサイトの「URL認識」ではここで切られてます。
と書きました、
先のQA
http://okwave.jp/qa/q5846754.html

ではそう見えますが、
No.2添付図4~6ではそうなってませんね。

「カンマがいけない」わけではなさそうです。

投稿日時 - 2010-04-26 19:02:39

お礼

カンマがいけないのでなければアンダーバーが曲者なのでしょうか?
謎の領域です。
なんであれ、一度貼りつけに失敗したら、そこまでしかURL認識されないアドレスだったのだ、とド素人はあきらめた方が良いのでしょうね。
今回は2回もお門違いなアドレスになってしまったので恥ずかしいことになりましたが、次回からは1回で済ませたい(コラ!)と思っております。
本当に御丁寧にありがとうございました。

投稿日時 - 2010-05-08 02:00:38

ANo.2

No.1 です。画像貼りを失敗したのでもう一度...


尚、
>1~3を見ると、
>Panth?on

ここでも "?"に置換されました。

大変申し訳ございませんが、この投稿に添付された画像や動画などは、「BIGLOBEなんでも相談室」ではご覧いただくことができません。 OKWAVEよりご覧ください。

マルチメディア機能とは?

投稿日時 - 2010-04-26 18:50:26

お礼

再度お手数おかけしました。
こういう「変容(??????)」については思いが及びませんでした。

投稿日時 - 2010-05-08 01:53:23

あなたにオススメの質問