こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

MPEGの再生異常

MPEGの再生が出来ず困っております。
下記の環境・症状なのですが、原因or解決策がお分かりになる方、ぜひアドバイスをお願い致します。

●環境
CPU: PentiumIII 1.13GHz
M/B: ASUS TUEG-VM (i815G)
OS: WindowsXP Professional SP1
App: Media Player 6/9, PowerDVD XP, QuickTime Player

●症状
・MPEG1ファイルの再生
 Media Player6/9…音声だけ再生され、画面が真っ黒
 PowerDVD…映像は映るが早送りの状態になる
 QuickTime…正常に再生
・MPEG2ファイルの再生
 Media Player6/9…上下が反転(鏡に映したような状態)
 PowerDVD…正常に再生

●補足
・上記の状態は、Medai Player 9のインストール前と後で変化はありませんでした。
・QuickTimeでの再生は、WinXPのユーザによっては正常再生されるものと、映像が表示されない(ウィンドウ下のデスクトップが表示されたまま)ものがいる状態です。(どちらもAdministrator権限のユーザ)
・試したMPEG1/2のファイルは、他のPCで正常に再生できることを確認したファイルです。
・AVIファイルの再生は正常にできています。
・DivX等の他のcodecは特にインストールしていません。

投稿日時 - 2003-08-14 11:05:52

QNo.627467

困ってます

このQ&Aは役に立ちましたか?

2人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.4

MPEG-1ファイルは標準で再生できると思います。
DirectShowフィルタがおかしくなっているのかも?
http://hp.vector.co.jp/authors/VA032094/DFTool.html

MediaplayerClassic6.4.6.0はMPEG-1デコーダを内蔵しているみたいです。
http://page.freett.com/edarapnug/mpc_j/

投稿日時 - 2003-08-23 22:48:33

ANo.3

MPEG1のファイルとあるファイルの内容は
多分 MOVのMPEG4だと 思われます。

これは QuickTime でしか 正常に 再生できないですよね。

うちでも、デジカメで撮影した動画が 同じような状態です。

投稿日時 - 2003-08-15 07:23:19

補足

takntさん、度々コメントありがとうございます。
けれでも、デジカメで撮影した動画も正しくMPEG1のようです。
# 再生できる端末で、真空波動研(ソフト名)で確認しました。
先に書きました通り、TMPGEncでエンコードしたMPEGファイルでも症状が同じなのです。
こういった状態ですので、拡張子と中身が一致していない、(DivX等で)必要なcodecがインストールされていない、といった症状とは違うのかなと思っております。

投稿日時 - 2003-08-16 17:43:40

PowerDVDのほかにMPEG2コーデックはインストールされてませんか(FreeDVD CodecとかDVDit!とかのオーサリングソフトに付属とか)、

以前FreeDVD CodecがインストールされていたWin2000にPowerDVDをインストールしてMPEG1が早送りになった事があり、
PowerDVDをアンインストールして正常になった事がありましたが。

投稿日時 - 2003-08-14 13:44:17

補足

コメントありがとうございます。
動画の再生や編集、DVDオーサリング等、影響を受けそうなソフトは、上記で挙げたソフトしか心当たりがないのです。

投稿日時 - 2003-08-14 21:02:39

ANo.1

そのMPEGは、どのようにして作成したものでしょうか?

投稿日時 - 2003-08-14 11:07:31

補足

コメントありがとうございます。
MPEG1ファイルは、
・SONYのデジカメで撮影したもの
・TMPGEncでエンコードしたもの(VideoCDフォーマット)
MPEG2ファイルは、
・NECのHDDレコーダで録画したもの
・TMPGEncでエンコードしたもの(CBR4Mbps)
です。
ファイル生成元が違うものでも、症状は同じでした。
やはり再生環境の問題でしょうか…

投稿日時 - 2003-08-14 21:04:57

あなたにオススメの質問