こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

Eclipse/MacのExtentions使い方

初めまして、Javaの勉強を始めたばかりの者です。
Macを使っています。
この度
/Library/Java/Extentions/にjarファイルを追加して追加したクラスを
使用するプログラムを作りました。
今後開発するにあたり、統合開発環境を使用していきたいと考えEclipseをインストールしました。
Eclipseで拡張ライブラリが使えず、もう何日も困っています。
どなたか助けて下さい。
/Library/Java/Extentions/に追加したjarファイルを使用するにはどうすれば良いのでしょうか?
何度も自分で試してみたのですが、どうしても追加したはずのクラスを使えないです。
プログラムの内容自体はコンソールで実行して見ているので間違いないはずなのですが、、、下記のようなエラーメッセージが出ます。
------------------------------------------------------------------------------------------------------
Exception in thread "main" java.lang.Error: Unresolved compilation problems:
Dodai を型に解決できません
Dodai を型に解決できません
------------------------------------------------------------------------------------------------------


新規プロジェクト作成のところから教えて頂きたいと思います。
宜しくお願い致します。

因みにEclipseを使わずコンソールから実行したファイルは下記の場所でした。
/Users/xxxx/JavaPro/Sample3-2/FusenExec.java
javac FusenExec.javaでコンパイル
FusenExec.classが出来る。
java FusenExecで実行

・下記にEclipseでプロジェクトを作成した手順を記します。
新規プロジェクトの作成
・ファイル>新規プロジェクト>Javaプロジェクト選択>JREの種類で「実行環境JREの使用」→JavaSE-1.6

・Java設定
JREシステム・ライブラリー「JavaSE-1.6」となっていて、配下に追加したjarファイルが表示されています。

・パッケージエクスプローラでsrcを選択
ファイル>新規>クラス
パッケージ名:jp.xxx.eclipsebook
名前:Sample
スーパークラス:java.lang.Object←元々書かれていた

・ソース
---------------------------------------------------------------------
package jp.kuu.eclipsebook;

public class Sample {

/**
* @param args
*/
public static void main(String[] args) {
// TODO 自動生成されたメソッド・スタブ
// 1枚目の付箋土台
Dodai fusen1 = new Dodai();
fusen1.setSize(200,50);
fusen1.setVisible(true);
}
}
---------------------------------------------------------------------------------
また、Eclipseで自動作成されたディレクトリの.javaファイルはターミナルからjavacコマンドでコンパイルしようとしても、コンパイル出来ませんでした。

何故なのでしょうか。何だか解らないことが多く、こんがらがって混乱しています。
どなたか助けて下さい。お願いいたします。


開発環境
・MacOS10.6.8
・java version 1.6.0_26(元々JDK(Java SE Development Kit)が入っていた。)
・拡張用ライブラリdodai.jarの場所は/Library/Java/Extensions/配下
・統合開発環境 Eclipse3.7
・日本語化 Pleiades1.3.3

大変申し訳ございませんが、この投稿に添付された画像や動画などは、「BIGLOBEなんでも相談室」ではご覧いただくことができません。 OKWAVEよりご覧ください。

マルチメディア機能とは?

投稿日時 - 2011-09-20 23:30:16

QNo.7024176

すぐに回答ほしいです

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.2

「Javaの道」と同じ人かな?
とりあえずパッケージ指定はダメです(「package jp.kuu.eclipsebook;」は削除).
以下ご参照ください.

参考URL:http://javaroad.jp/bbs/answer.jsp?q_id=20110918201120589

投稿日時 - 2011-10-01 10:43:02

同じ内容で質問してるひとがいるのでこちらを参考に
http://javaroad.jp/bbs/answer.jsp?q_id=20110918201120589

投稿日時 - 2011-09-21 09:56:06

あなたにオススメの質問