こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

wi-fiアダプタのセットアップについて

wi-fiアダプタのセットアップについて

有線接続のパソコンに無線USBアダプタを挿してwi-fi環境を構築しようとしています。
今回購入したのは、ELECOM Logitec制のLAN-W150NU2AWというものです。
使用しているパソコンはWindows7 home premiumです。

付属マニュアル通りに、CDーRをセットし手順通りにセットアップを行いました。
「無線アダプタを接続してください」と表示されたので無線アダプタを挿したところ、
しばらくお待ちくださいのまましばらく経っても何もならなかったので確認してみると、
インストール出来ませんでしたのようなエラーがタスクバーに表示されました。

何度かアンインストールとセットアップを繰り返してみたのですがドライバのインストールが出来ません。
しかしタスクバーには黒いロゴらしきものは表示されています。
ポインタを合わせてみると「IEEE802.11 WLANが存在しない」などと表示されます。
他は終了以外選択できません。
デバイスマネージャーを見てみると、このアダプタの名前は表示されず、代わりに
「ネットワークアダプター」の「802.11 n WLAN」として認識されているようです。

パソコンにあまり詳しくないので意味不明なことをしていたら指摘願います。
ドライバをインストールするにはどのような方法がありますでしょうか?
もしくは商品自体に問題があるのでしょうか・・・?

色々調べてみたのですが、みなさんセットアップ自体は何も問題なく完了しているようです。
問題はその後の、親機モードとして使用する、にあるようです。
私のようにセットアップ自体完了しない項目が見当たらなかったので質問させていただきました。


わかりやすく回答していただけるととても助かります。
よろしくお願いします。

投稿日時 - 2014-04-21 15:08:54

QNo.8563221

すぐに回答ほしいです

質問者が選んだベストアンサー

No7です
>チェック項目が表示されません。
これについては こちらでも 802.11 n WLAN の削除の時はチェック項目はありません
項目が表示されてるのは実際に外部ドライバをインストールしたデバイスだけです
ですのでOS標準のドライバでご認識されてしまっているのではないかと
(全くの初期OS状態では確認できないので何か他に要因があるのかもしれません)

>ドライバの削除をすると、USBを挿したままでもデバイスマネージャの
>一覧から消えるものなのでしょうか?
ということは削除してるけど消えないってことのようですね
此方では消えています (そのまま再スキャンかければ復活表示されます)
書かれてる手順で間違って時はいないと思いますが念のため参考にしてください
http://121ware.com/qasearch/1007/app/servlet/relatedqa?QID=012078

>Windows7 32bitなのですが64bitとやり方が違う等あるのでしょうか?
64ビット使ってないので正確にはわかりませんが同じだと思います

似たような現象を簡単に検索した中で  これならいけるんではないか
と感じたのがセーフモードでの確認(削除)です
デバイスマネージャの[表示]メニューから[非表示デバイスの表示]を選択する 
を選択すればデバイス挿さなくても表示・削除ができるはずです

セーフモードの起動方法は以下でも参考に
http://esupport.trendmicro.com/solution/ja-jp/1309997.aspx

投稿日時 - 2014-04-23 00:29:58

お礼

セーフモードからドライバの削除を行ったところ完全に削除することが出来ました。

その後のセットアップも何度か失敗しましたが(インストールが完了しなかった)
何度か試したところ無事セットアップ完了することが出来ました!

APモードで起動も出来き、スマホで接続することも出来ました!

ただスマホで接続しても、無効のwi-fiです。等でネットに繋ぐことができません…。

しかしこれらの問題はこの質問とは別問題かと思うので、質問の内容については無事解決したので締め切りにします。

要因は違うドライバで認識されてしまっていたことと、ドライバの削除を完全に行えていなかったことなのかな?と思います。

私の不十分な説明と無知にも関わらず数日に渡って回答下さって心より感謝申し上げます。
回答いただけなければ、そして的確に問題点を指摘して下さらなければ投げ出していたところでした。
本当にありがとうございました。

投稿日時 - 2014-04-23 04:54:18

ANo.8

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(8)

ANo.7

No6です  ちょっと手順を確認してみました
No6の手順はあまりいいものではありませんでした

ちょっと話がごちゃごちゃしてきたのもあるため改めて整理します
ひょっとしたら Pro・Home の違いで表示などが一部異なるかもしれません

ドライバのアンインストール手順について
デバイスをUSBに挿すとデバイスマネージャにNIC認識される形になっていると思います
デバイスマネージャで そのNICを選択・削除 を選ぶと表示されるDialogに
このデバイスのドライバーソフトウエアを削除する  のチェック項目があるはずです
そこにチェックを付けて OK を押してみてください
NICが一覧表示から削除されるはずです

ドライバの削除としてはこれで終わりです(挿し直しとかはNGでした)
もしチェック項目が表示されないのであれば
OS標準のドライバで組み込まれているのかもしれません
チェックがない場合はそのままOK を押して一覧から表示が消えることを確認してください

一応 両方のデバイスでこの動作を行ってください(先にPLANEX 次にLOGITEC)
    此方の環境でここまでの動作を行って そのままハードウエア変更のスキャン
    を実行すると正常認識はされないもののその他のデバイスとして
    802.11 n WLANが表示されます(この確認はやる必要ありません)

デバイスを抜いて Logitecのインストーラを起動してください
    抜くとき注意しないと再度デバイス認識してしまうことがあるので注意
    (通知領域にポップアップ表示されるのでわかるはず)
以前のアプリの残骸が残っているはずなのですべて削除の操作から始まると思います
終了後再度インストーラを起動してください(↑では削除が終わっただけです)

インストール完了後 デバイスをUSBに挿してみてください
ここで正常な認識がされてドライバのインストールがされないでしょうか?

No5 で削除ができないとかあったと思いますが
今回この方法でも削除できないでしょうか?(一覧からも消えませんか?)
    一覧から消すことができないのか
       (消せないのに削除項目はあるのか  項目がなくて消せないのか)
    再スキャンなどで現れてきて消せないって意味なのかわかりません
       今回こちらで見たところ 再スキャンなどすると
       消えない(再度あらわれる)のはある意味正常なのかもしれません

多分一覧に残った状態でインストールしてるためにエラーになるのではないかと


とりあえずここまで確認してみてください
それでも改善されないとなると本腰入れてPLANEXで
再度確認のほうが良いのかもしれません

>IPアドレスは:192.168.3.2
であればとりあえず私の脳裏をかすむ不安は多少改善されます
XPだと192.168.0.0/24 だと ICSでトラブルので
手元の7で見る限り上記ICSの仕様が変わった?様で
何となくセグメントも適当なところを割り当ててるような気もしてます

投稿日時 - 2014-04-22 17:55:14

お礼

回答感謝いたします。

USBを挿してデバイスマンージャを開き、
[右クリック]-[削除]-[OK]
で今までやっていました。
しかし一覧からは消せません…。
そもそも基本的なやり方が間違っているのでしょうか?(汗

デバイスマネージャで そのNICを選択・削除 を選ぶと表示されるDialogに
このデバイスのドライバーソフトウエアを削除する  のチェック項目があるはずです
そこにチェックを付けて OK を押してみてください
NICが一覧表示から削除されるはずです

とありますが、チェック項目が表示されません。

ドライバの削除をすると、USBを挿したままでもデバイスマネージャの一覧から消えるものなのでしょうか?
だとしたら今まで消せてなかったのかもしれません…

もう一度やり方から調べてみます。
Windows7 32bitなのですが64bitとやり方が違う等あるのでしょうか?

お時間あればご教授願います。
回答感謝いたします。

投稿日時 - 2014-04-22 23:35:16

ANo.6

>一度こうなる前にシステムの復元をしたときにはドライバごと消えたのですが(当然かと思いますが)
>今回それをしたらアンインストールした以前のドライバも復元してしまいますよね…?

復元しますね  ドライバ毎消えたことがあるというのと
消えてからの操作で何やられたのかよくわからないので
普段ならあまり安易なシステムの復元をお勧めしたくはないのですが
今回は多分それほど大きな問題にはならないであろうことから
(今回のトラブル操作の間に新たにソフトインストールしたとかやってれば別)
ドライバ削除できたことがあるなら一旦その時点まで復元して
再度ドライバ削除を行ったほうが早いかもしれません


手順として以下の順で行ってみてください
・システム復元(ドライバも復活・ 上記一度こうなる前~~の状態に戻す)
・GW-USNan2 をPCに挿す(元々と同じUSBポートに挿してください)
   別ポートに挿すとドライバの登録情報が残って
   完全に削除できないといった事があるかもしれませんります
 この段階で「802.11 n WLAN」として認識 されているか確認してください
 (おそらくそう認識されているはずです
・プログラムの機能でGW-USNan2 を削除する
 この段階で「802.11 n WLAN」がデバイスから消えているかを確認してください
・GW-USNan2 を抜いて PC再起動してみてください
・再起動後改めてGW-USNan2 を同じポートに挿してデバイスが新規認識され
 ドライバ要求されるか確認してください
 セットアップメッセージに従ってドライバに自動検索などさせても
 同じ名前でドライバの再登録がされないことを確認してください
 (ドライバのインストールは失敗してGW-USNan2 が認識されないことを確認する)

※ XLink Kaiに関しては良くわかってませんがその関係で
  何か別にプログラムがあるようでしたらそれも合わせて削除してください

↑それが確認できればドライバは削除されているはずですので
改めてGW-USNan2 を抜いた上でPC再起動して
LAN-W150NU2AW の再セットアップを行ってみてください
インストールの際 LAN-W150NU2AW は GW-USNan2 を抜いたポートに挿してください

この手順でうまくいかないようであれば
どこまでできてそこでどのような現象になっているのかを再度補足してみてください


GW-USNan2 のドライバでの誤認が原因であることはほぼ間違いないので
デバイスマネージャで自分で意図的に 「802.11 n WLAN」を削除 とかしなくていいです

場合によってはGW-USNan2 でAPモードにできない原因を調べて
解決図ったほうが良いのかもしれません
  この場合気になる点として 現状の LANのセグメントをついでに補足してください
  ↑ No4 のお礼に書かれた  IPアドレス等で確認しました
  で 表示された サブネットマスクと IPアドレス情報がそれに該当します
  たぶん サブネット 255.255.255.0
  IPアドレス 192.168.AAA.BBB といったものだと思いますが
  その2つの情報を教えてください
  これはローカルIP情報なのでそれを書いても
  個人特定できるような情報ではありません

投稿日時 - 2014-04-22 13:02:55

お礼

再度回答感謝いたします。

システムの復元が過去のデータが上書きされてしまい、デバイスごと削除するときまで戻ることができませんでした(汗

なのでシステムの復元以降からの手順を踏んでみたところ(プログラムの削除はすでにしてある状態)

GW-USNano2を挿してみたところ、ドライバも削除したのにGW-USNano2として認識されました。
LAN-WNU2AWを挿してみると、やはり802.11nとして認識されてしまいます。
ドライバーソフトウェアの更新をしてみると、

「デバイス用のドライバーソフトウェアが見つかりましたが、このドライバーのインストール時にエラーが発生しました。

Logitec LAN-W150N/U2 LAN Adapter

アクセスが拒否されました。」

と出ます。参考にならなかったらすいません。

IPアドレスは:192.168.3.2
サブネットマスク:255.255.255.0

です。以下手順で出来なかったこと等記入します。

-----------------------------
・システム復元(ドライバも復活・ 上記一度こうなる前~~の状態に戻す)【×出来ませんでした。】

・GW-USNan2 をPCに挿す(元々と同じUSBポートに挿してください)
   別ポートに挿すとドライバの登録情報が残って
   完全に削除できないといった事があるかもしれませんります
 この段階で「802.11 n WLAN」として認識 されているか確認してください
 (おそらくそう認識されているはずです【GW-USNan2として認識されました。USBデバイスとしての取り外し等も出来ます】

・プログラムの機能でGW-USNan2 を削除する
 この段階で「802.11 n WLAN」がデバイスから消えているかを確認してください【GW-USNan2プログラムはアンインストール済みです】

・GW-USNan2 を抜いて PC再起動してみてください

・再起動後改めてGW-USNan2 を同じポートに挿してデバイスが新規認識され
 ドライバ要求されるか確認してください
 セットアップメッセージに従ってドライバに自動検索などさせても
 同じ名前でドライバの再登録がされないことを確認してください
 (ドライバのインストールは失敗してGW-USNan2 が認識されないことを確認する)【ドライバ要求されず、普通にGW-USNan2として認識されてしまいます。】

投稿日時 - 2014-04-22 15:47:04

ANo.5

No4 です
>PPPoEが知識不足で調べてもあまりわからないのですが…
>モデムはルータ内臓のモデムみたいです(IPアドレス等で確認しました)
であれば PPPoE はそのルータ内蔵モデムで行っているので気にする必要ありません

>別のドライバで認識されてしまっているとしたらどういったことをすればいいのでしょう?
手元にあればいろいろやってみるところなんですが
とりあえずデバイスマネージャで
「ネットワークアダプター」の「802.11 n WLAN」として認識  を削除してください
  この作業はデバイス挿してないとできないはずです
↑多分今まで意識的に削除はしていなかったかと思います

削除後デバイスドライバの再インストールを行ってみてください
(ここで削除するか確認されているはず)

もしかしたら再起動要求されるかもしれませんが
再起動はしないままにやってみてください
(それでだめなら今度は再起動したうえで同じことをやってみてください)
再起動した時デバイス要求されるかと思いますがキャンセル
若しくはアダプタ抜いた状態で再起動してください

さらに無理やりなこと言えばキャンセルではなく
そのままの状態で再セットアップしたらどうなるか  とか

セットアッププログラムを単独解凍出来てドライバだけを
抜き出せればもう少しやり方もあるのですが
此方で試したところそれは難しそうです


>以前PSPのモンハンをしょうと、
>XLink Kaiというものに繋ぐために似たような
>wifiアダプタを購入して設定したことがあります。(同じ環境同じパソコンです)
あ~ チップが同じでそっちのドライバで認識されてる可能性が高いです

>そのアダプタはGW-USNan2なのですが
PLANEXですね これまた偶然にも私もPLANEXの似たようなUSBアダプタ保有しています
先に書いたPCで全てインストールしてますが競合などは特に発生していません
(XLink Kaiは使ったことないのでよくわかっていません)

>結局電波は拾えてもスマホから接続出来ずに諦め新たに今回のアダプタを購入した
本来はそちらだけで対応できていいはずなんですけどね
こういったUSBアクセスポイントは変な環境依存があったりするので

>それと干渉してる、とかあるのでしょうか?
先に書いたように多分その無線アダプタと誤認されてしまっています

プログラムの機能の方からGW-USNan2のソフト・ドライバ削除できるはずなので
それをやってから再度セットアップすればそれで話が終わるかもしれません
(もしかしたらインストール順なども影響するのかもしれません)
ちなみに私が持ってるPLANEXアダプタは GW-USWExtreme

投稿日時 - 2014-04-21 22:28:47

お礼

回答ありがとうございます。
ためしに以前のGW-USNan2の方はアンインストールし、
再度CD-Rのセットアップを行ったところ、少々違いが見られました。

無線アダプタを接続して下さい

と表示された後アダプタを挿すと、以前は何もならなかったのが、今度は

無線アダプタの接続に問題があります。一度取り外して接続し直して下さい。

と表示されるようになりました。
このヘルプを見てみると、

[エラーコード:16-01-0075-99]
無線アダプタの安全な取り外しが行われましたが、
無線アダプタが物理的に取り外されていません。

となります。もちろん物理的に抜き差ししてます。
通常なら安全な取り外しの手順を踏んでから抜き差ししますが、USBデバイスとして認識されていないからかタスクバーに表示されないので、何もしないまま何度か抜き差しを行いました。
しかしこのエラーが表示されます。

デバイスの削除や上記の手順等色々試してみましたが
どうしても「ネットワークアダプター」の「802.11 n WLAN」が削除できません。
削除を選択し、そのままアンインストール後再びセットアップしてみましたが消えません。

一度こうなる前にシステムの復元をしたときにはドライバごと消えたのですが(当然かと思いますが)
今回それをしたらアンインストールした以前のドライバも復元してしまいますよね…?

誤認識したドライバ?を元に戻せれば解決するような気がします。
少々前進した気がします、心から感謝いたします。
もし何か別の方法があれば助言お願いします。

投稿日時 - 2014-04-22 00:50:55

ANo.4

No3 です
PCの環境がわからないので確認させてください
・使ってるのはデスクトップ・ノート どちらですか?
 PCの型番がわかっているならその補足でも構いません
   ノートとかの場合 内蔵無線LAN 等と競合してる可能性もあります

・現在有線でつなげているとありましたが
 これは有線ルータにつながっている と考えていいですか?
 それともルータは存在していなくて PPPoE 自体の設定を
 PCで直接行っている  どちらでしょうか?

・使ったのは LST-D-288 Ver2.00 かと思いますが
  LST-D-288 Ver1.11 使っても同じですか?


全く同じ環境ではありませんがこちらでもノートPC(内蔵NIC有効のまま)
Win7(Pro 32bit)+ LAN-W150N/U2BK使って APモード動いています
(数年前に買ったのであなたが買ったのより古いはず)
ただしこちらの現在の環境は元が無線なのでAPモードで使う意味自体が殆どないんすが

PC直接 PPPoE にした場合の確認ってのはこちらでもできませんが
少なくてもソフトのインストールに 既存の回線がきちんと準備されている
されていない が影響することはありませんので
>ルータがない
とか言った事は関係ないと考えてください(今はその前段階の話です)

なんか本来のデバイスドライバで認識されているんではなくて
何か別のドライバとして認識されてしまっているような気がします
その為にソフトも正常動作をしないということではないかと思います
だからNICも 802.11 n WLAN 認識ってことなのかもしれません
此方で確認したところ Logitec LAN-W150N/U2 LAN Adapter と認識されています

投稿日時 - 2014-04-21 19:52:08

お礼

追っての回答感謝いたします。
パソコンはデスクトップです。
有線接続は、
ネット―モデム―パソコン
です。モデムはルータ内臓のモデムみたいです(IPアドレス等で確認しました)

PPPoEが知識不足で調べてもあまりわからないのですが…
ソフトバンクのホワイトBBで付与されたモデムで、最初何の設定もなく、モデムに線を繋いだだけでネットに繋がりました。(検討違いな回答だったらすいません)
モデムから線で直接パソコンに繋がってます。

別のドライバで認識されてしまっているとしたらどういったことをすればいいのでしょう?

全然関係ないことだったら飛ばしていただきたいのですが、
以前PSPのモンハンをしょうと、XLink Kaiというものに繋ぐために似たようなwifiアダプタを購入して設定したことがあります。(同じ環境同じパソコンです)
そのアダプタはGW-USNan2なのですが、今でも設定はそのままで、これでもなるのかとアクセスポイントモードに切替たりスマホでwifi接続しようとしたり色々いじりました。
結局電波は拾えてもスマホから接続出来ずに諦め新たに今回のアダプタを購入したのですが、それと干渉してる、とかあるのでしょうか?(アダプタは抜いて起動もしてません)

ver1.1の方でも試してみます。

投稿日時 - 2014-04-21 21:09:42

ANo.3

最終的に何をやりたいのかよくわかりませんが
>「ネットワークアダプター」の「802.11 n WLAN」として認識されているようです。
であればドライバ自体のインストールは終わっています

問題は 「IEEE802.11 WLANが存在しない」 の方です
そこで最初に書いた 何をやりたいのかよくわからない に行くのですが
あなたがやりたいのは
・既に無線の親機があって 無線子機としてPCを接続したい
・有線環境のPCに親機動作ができる無線USBを指して無線化して
 ゲーム機などを無線で接続したい
・それ以外(正直これはどんなことやりたいのか全く想像つかない)

どれなのでしょうか
親機があって 「IEEE802.11 WLANが存在しない」 の表示がされるのはおかしいですが
親機がない状態で 「IEEE802.11 WLANが存在しない」 が表示されるのは当たり前です
後者であればソフト設定で
(多分 タスクバーには黒いロゴらしきものというやつで設定できるはず)
動作モードを変更する必要があります

他の回答で対応してないとか書かれてますがWindows7 home premiumnなら
対応してるはずです
(iWin7 の一部エディションには対応していません 下までちゃんと読めば書いてある)

詳細はユーザマニュアル確認してください(以下からでも入手可能)
http://dl.logitec.co.jp/download.php?pn=LAN-W150U2_GMW_um_v02.pdf&ipn=LAN-W150NU2AW

投稿日時 - 2014-04-21 17:57:32

お礼

回答ありがとうございます。
説明不足&知識不足ですいません(汗

やりたいことは、
有線環境のPCに親機動作ができる無線USBを指して無線化してゲーム機などを無線で接続したい
です。

ソフト設定で動作モードを変更、とありますが、タスクバーにある黒いロゴを右クリック→設定画面を開きます をクリックしても何もなりません…終了以外何も出来ません。
セットアップ自体は完了している、ということでしょうか?
となるとご指摘通り、ルータがない等他の問題とのことでしょうか??

投稿日時 - 2014-04-21 18:24:54

ANo.2

一度、ホームページからソフトをダウンロードし、試してみては。

投稿日時 - 2014-04-21 17:10:31

お礼

付属CD-Rではなく、ホームページからダウンロードしても試してみたのですがダメでした…

ドライバも手動で更新、も調べながらやってみたのですがドライバが見つかりません、とのことで出来ませんでした…

投稿日時 - 2014-04-21 17:21:56

商品の仕様を確認するとWindows7では『親機モード』は対応していない様です。

http://www.logitec.co.jp/products/wlan/lanw150nu2a/index.php

このページでは『ルータ』が必要と有る。

投稿日時 - 2014-04-21 15:47:41

お礼

回答ありがとうござます。
ルータがないとセットアップすら出来ないということでしょうか?
親機・子機選択以前にインストールすら出来ないのですが…

無知ですいません(汗

投稿日時 - 2014-04-21 16:05:01

あなたにオススメの質問