こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

WinのピアトゥピアLANについて

Win95,WinMe,Win2KProでサーバを設置しないピアトゥピアのLANを構築しようとして躓いています。現在NETBEUIで稼動しているのですが,これをTCP/IPに変更しようと思っています。
それぞれのマシンからNETBEUIを削除し,固定のIPアドレスを振りました(ワークグループ名はNETBEUIの時のまま)。

各々のマシンでは「ネットワークコンピュータ」等では他のマシンが表示されないので,PINGを確認したところ,

WinMe→Win95 ○
WinMe→Win2K ×
Win2K→Win95 ○
Win2K→WinMe ×
Win95→WinMe ×
Win95→Win2K ×

という状況です。

MicroSOFTネットワーク共有サービス,ネットワーククライアントは全てのPCで設定済。当然ワークグループ名も統一できています。

うまくつながらない原因にどんなことが考えられるでしょうか。

投稿日時 - 2004-09-12 21:41:01

QNo.999211

すぐに回答ほしいです

質問者が選んだベストアンサー

Win95以外のマシンにパーソナルファイアウォールが入っていたりしませんか?

Windowsドメイン関係と、ファイル・プリンタ共有関係のポートが閉じられていたりしませんか?

Win2Kはネットワークの設定にもポート制御が出来る部分がありました。Meは使ったことがないんでわかりませんが、2Kと同時期なんで、同様の設定があるかな?

big_egg さんのアドバイスの部分と、上記の部分がクリアで来てれば見えるはずなんですがねぇ。
NETBEUIではつながってたんですから、ハード的な問題とも思えないし。

「ネットワークコンピュータ」のワークグループツリーの下に各マシン名が出てこないと、どうしようもないですから、困りますよね。

私も、謎解きしながら使ってますが、何とも不可解な現象に悩まされることがあります。
慰めにしかならないですが・・・

投稿日時 - 2004-09-12 23:15:24

お礼

WinMeでウィルスバスターが稼動していますので、こいつを止めてみました。・・・解消しませんねぇ。

PINGの片側通行というのが、素人の私には全然理解できないです。
ただ、皆さんからのアドバイスで私の作業に大きなミスはなさそうですから、もう少しいろいろと試してみます。
ありがとうございました。

投稿日時 - 2004-09-13 20:04:54

ANo.4

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.3

各PCのIPアドレスとサブネットマスクを下記のように設定してもう一度PINGを確認してみて下さい。

WIN95
192.168.0.1
255.255.255.0

WINME
192.168.0.2
255.255.255.0

WIN2000
192.168.0.3
255.255.255.0

では。

投稿日時 - 2004-09-12 22:13:38

お礼

ありがとうございます。
これで試してみましたが、同じ現象ですね。

投稿日時 - 2004-09-13 20:01:54

ANo.2

#1です。
ウイルスチェックソフトを消し去ってください。

投稿日時 - 2004-09-12 21:58:31

ANo.1

PINGが通らないとは、共有以前の話ですね。
図の○を見ると「WinME:Win95」はOK、「Win2k:Win95」もOKとすると、受け側の時のWin95だけOKということですね。こういう状況はまったく考えにくいです。LANボードの故障でしょうか。○のpingを「ping 192.168.0.1 -t」として、継続実行させてみて、エラーが発生するか、安定しているのか確認してください。
それと、他に機器はLANに乗っていないでしょうか?IPアドレスはバッティングしていないでしょうか?

投稿日時 - 2004-09-12 21:57:25

お礼

アドバイスありがとうございます。
NETBEUIで問題なく使えているので、LANボードやHUBの障害は考えにくいのではないかと思っています。

投稿日時 - 2004-09-13 19:59:48

あなたにオススメの質問